Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
Browse files

Update demo app to work on ruby 1.9.2.

  • Loading branch information...
commit 5be0272e565a69c0f33cb7c01326e1e233f6c857 1 parent 774243b
@brightchimp authored
Showing with 8 additions and 24 deletions.
  1. +7 −23 doc/demo/Gemfile
  2. +1 −1  doc/demo/test/unit/content_test.rb
View
30 doc/demo/Gemfile
@@ -1,5 +1,9 @@
source 'http://rubygems.org'
+# Don't use latest version of rake:
+# http://stackoverflow.com/questions/6199301/global-access-to-rake-dsl-methods-is-deprecated
+
+gem 'rake', '0.8.7'
gem 'rails', '3.0.9'
# Bundle edge Rails instead:
@@ -7,28 +11,8 @@ gem 'rails', '3.0.9'
gem 'mysql'
+# Until branch is merged into master, the tests will fail.
+# To get everything running use the brightchimp gem.
gem 'acts_as_ferret'
+#gem 'acts_as_ferret', :git => 'git://github.com/brightchimp/acts_as_ferret.git'
gem 'will_paginate', '3.0.pre2'
-
-# Use unicorn as the web server
-# gem 'unicorn'
-
-# Deploy with Capistrano
-# gem 'capistrano'
-
-# To use debugger (ruby-debug for Ruby 1.8.7+, ruby-debug19 for Ruby 1.9.2+)
-# gem 'ruby-debug'
-# gem 'ruby-debug19', :require => 'ruby-debug'
-
-# Bundle the extra gems:
-# gem 'bj'
-# gem 'nokogiri'
-# gem 'sqlite3-ruby', :require => 'sqlite3'
-# gem 'aws-s3', :require => 'aws/s3'
-
-# Bundle gems for the local environment. Make sure to
-# put test-only gems in this group so their generators
-# and rake tasks are available in development mode:
-# group :development, :test do
-# gem 'webrat'
-# end
View
2  doc/demo/test/unit/content_test.rb
@@ -1,4 +1,4 @@
-# coding: UTF-8
+# encoding: UTF-8
require File.expand_path(File.dirname(__FILE__)) + '/../test_helper'
require 'pp'
require 'fileutils'
Please sign in to comment.
Something went wrong with that request. Please try again.