Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

NetId filter with basicstation #157

Closed
istina-iot opened this issue Jan 17, 2020 · 1 comment
Closed

NetId filter with basicstation #157

istina-iot opened this issue Jan 17, 2020 · 1 comment

Comments

@istina-iot
Copy link

@istina-iot istina-iot commented Jan 17, 2020

Is this a bug or a feature request?

Bug: bridge or basicstation?

What did you expect?

Filtering packets by NetId for custom NetId numbers or filtering disable, according to bridge config

What happened?

all packets always filtered by NET ID=000000

What version are your using?

3.6

How can your issue be reproduced?

Try filters any net with basicstation, except 000000 and try run bridge without filtering

Could you share your log output?

bridge logs:

INFO[0000] starting ChirpStack Gateway Bridge            docs="https://www.chirpstack.io/gateway-bridge/" version=3.6.0
INFO[0000] filters: NetID filter configured              net_id=000000

bridge config:

cat ./chirpstack-gateway-bridge.toml | grep net_ids
net_ids=["888888"]

basicstation log:

2020-01-17 09:52:38.220 [S2E:VERB]   NetID filter: 00000001-00000001-00000001-00000001
@brocaar brocaar closed this in ebcc1dc Jan 17, 2020
@brocaar

This comment has been minimized.

Copy link
Owner

@brocaar brocaar commented Jan 17, 2020

Thanks, this should be fixed with the above commit.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
Linked pull requests

Successfully merging a pull request may close this issue.

None yet
2 participants
You can’t perform that action at this time.