New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Ansible local provisioner error #3

Closed
Howlinmoon opened this Issue Feb 15, 2017 · 3 comments

Comments

Projects
None yet
2 participants
@Howlinmoon

Howlinmoon commented Feb 15, 2017

Clone the repo
ran "vagrant up"

the install erred out with the messages shown below.

NOTE - the messages shown below are the result of a followup attempt, since I was unable to copy the output from the original attempt.

biff@obsidian:~/lora/loraserver-setup$ vagrant up
Bringing machine 'vagrant' up with 'virtualbox' provider...
There are errors in the configuration of this machine. Please fix
the following errors and try again:

ansible local provisioner:

  • The following settings shouldn't exist: install_mode
@brocaar

This comment has been minimized.

Show comment
Hide comment
@brocaar

brocaar Feb 15, 2017

Owner

Could you check which version of Vagrant you're using? You might need to upgrade it :-)

Owner

brocaar commented Feb 15, 2017

Could you check which version of Vagrant you're using? You might need to upgrade it :-)

@Howlinmoon

This comment has been minimized.

Show comment
Hide comment
@Howlinmoon

Howlinmoon Feb 15, 2017

Ah, I was using 1.8.1.
I guess that wasn't "recent" enough ;-)

It's chugging along now with 1.9.1

Howlinmoon commented Feb 15, 2017

Ah, I was using 1.8.1.
I guess that wasn't "recent" enough ;-)

It's chugging along now with 1.9.1

@brocaar

This comment has been minimized.

Show comment
Hide comment
@brocaar

brocaar Feb 15, 2017

Owner

Great!

1.8.1 (December 21, 2015), maybe not ;-) Looking at the Vagrant changelog, 1.8.7 (November 4, 2016) should be the minimal version as it fixes some Ansible (local) related issues. I'll add it to the docs.

Owner

brocaar commented Feb 15, 2017

Great!

1.8.1 (December 21, 2015), maybe not ;-) Looking at the Vagrant changelog, 1.8.7 (November 4, 2016) should be the minimal version as it fixes some Ansible (local) related issues. I'll add it to the docs.

@brocaar brocaar closed this May 3, 2017

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment