0.74 launch fails in 10.6 #54

Closed
GoogleCodeExporter opened this Issue Mar 3, 2015 · 5 comments

Comments

Projects
None yet
1 participant
What steps will reproduce the problem?
First time running csshx, noticed Issue 47: 0.74 launch fails in 10.7.
may be related?

1. Downloaded and copied csshx to /usr/local/bin

bash-3.2$ ls -alF /usr/local/bin/csshx
-rwxr-xr-x@ 1 root  wheel  84296 Sep 26 10:45 /usr/local/bin/csshx*


What is the expected output? What do you see instead?

Ran in terminal:

bash-3.2$ csshx --login bob sys1 sys2
No master at /usr/local/bin/csshx line 1179.


A new window popped open with the following:

Last login: Wed Sep 26 11:28:20 on ttys037
history -d $(($HISTCMD-1)) && clear && exec '/usr/local/bin/csshx' '--master' 
'--sock' '/var/tmp/tmp.0.grJLtI' '--launchpid' '82470' '--screen' '0' '--debug' 
'0' '--tile_y' '0' '--tile_x' '0' '--login' 'bob'
[s]% history -d $(($HISTCMD-1)) && clear && exec '/usr/local/bin/csshx' 
'--master' '--sock' '/var/tmp/tmp.0.grJLtI' '--launchpid' '82470' '--screen' 
'0' '--debug' '0' '--tile_y' '0' '--tile_x' '0' '--login' 'bob'
Illegal variable name.
[s]% 


What version of csshX (do a "csshX -v") are you using? On what operating
system version (do a "sw_vers")?

bash-3.2$ csshX -v
csshX  0.74
bash-3.2$ sw_vers
ProductName:    Mac OS X
ProductVersion: 10.6.8
BuildVersion:   10K549

bash-3.2$ /usr/bin/perl -MPOSIX -e 'print $POSIX::VERSION."\n";'
1.13

bash-3.2$ /usr/bin/perl -MPOSIX -e 'print POSIX::tmpnam."\n";'
/var/tmp/tmp.0.9f2beZ
bash-3.2$ touch /var/tmp/tmp.0.9f2beZ
bash-3.2$ 



Original issue reported on code.google.com by dkienenb...@alaska.edu on 26 Sep 2012 at 7:46

Sorry typo in the issue title 10.6, not 10.5

Original comment by dkienenb...@alaska.edu on 26 Sep 2012 at 7:48

Ok - this smells like a shell issue. "Illegal variable name" implies that it 
doesn't like the csshX command. I suspect it's the history part.

Are you using something other than 'bash' as your shell?


Original comment by ga...@brock-family.org on 27 Sep 2012 at 12:28

  • Changed title: 0.74 launch fails in 10.6
  • Changed state: Accepted
I usually use tcsh, tried it with bash, and it worked fine thanks! 

Original comment by dkienenb...@alaska.edu on 27 Sep 2012 at 12:48

Good to hear you got it working. It should have detected a non-bash shell and 
skipped the "history" bit. How did you choose the shell. With "chpass", or in 
the terminal prefs? chpass tends to be more reliable.

Original comment by ga...@brock-family.org on 27 Sep 2012 at 1:08

  • Changed state: Done
Its shell I've set as my default in my account information, so chpass would be 
accurate. 

Original comment by dkienenb...@alaska.edu on 27 Sep 2012 at 5:33

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment