Skip to content
A tool to automatically fix Django deprecations.
Python Makefile
Branch: master
Clone or download

README.md

Django Codemod

PyPI Build Status Test Documentation Status Updates

All Contributors

A tool to help upgrade Django projects to newer version of the framework by automatically fixing deprecations.

Installation

Install this via pip (or your favourite installer):

pip install django-codemod

Usage

To fix deprecations removed in Django 4.0:

djcodemod --removed-in 4.0 .

This will go through all the files under your local directory, under . and apply code modifications to help upgrading to Django 4.0.

Check out the documentation for more detail on usage and the full list of codemodders.

How it works

This is based on libCST and implements codemods for it. This is currently very limited but the aim is to add more for helping with upcoming deprecations.

Codemodders are grouped by the version of Django where a function or feature is removed.

Not finding what you need? I'm open to contributions, please send me a pull request.

Contributors

Thanks goes to these wonderful people (emoji key):


Bruno Alla

💻 🐛 📖

Adam Johnson

📖

Nikita Sobolev

📖

This project follows the all-contributors specification. Contributions of any kind welcome!

Credits

This package was created with Cookiecutter and the audreyr/cookiecutter-pypackage project template.

You can’t perform that action at this time.