Permalink
Browse files

working ruby 1.9.2

  • Loading branch information...
1 parent 2267f54 commit 0c2a16659831c30b128891963585a85ae8fd8997 @brownman committed Nov 4, 2012
Showing with 503 additions and 45 deletions.
  1. +16 −3 Gemfile
  2. +57 −40 Gemfile.lock
  3. +14 −2 Gemfile~
  4. +16 −0 bin/autospec
  5. +16 −0 bin/erubis
  6. +16 −0 bin/haml
  7. +16 −0 bin/heroku
  8. +16 −0 bin/html2haml
  9. +16 −0 bin/htmldiff
  10. +16 −0 bin/jasmine
  11. +16 −0 bin/launchy
  12. +16 −0 bin/ldiff
  13. +16 −0 bin/lessc
  14. +16 −0 bin/rackup
  15. +16 −0 bin/rails
  16. +16 −0 bin/rake
  17. +16 −0 bin/rake2thor
  18. +16 −0 bin/rdoc
  19. +16 −0 bin/restclient
  20. +16 −0 bin/ri
  21. +16 −0 bin/rspec
  22. +16 −0 bin/sass
  23. +16 −0 bin/sass-convert
  24. +16 −0 bin/scss
  25. +16 −0 bin/therubyracer
  26. +16 −0 bin/thin
  27. +16 −0 bin/thor
  28. +16 −0 bin/tilt
  29. +16 −0 bin/tt
View
19 Gemfile
@@ -1,19 +1,32 @@
source 'https://rubygems.org'
-ruby '1.9.3'
-gem 'rails', '3.2.2'
+#ruby '1.9.3'
+
+#gem 'bundler', '1.2.0.pre'
+gem 'rails', '3.2.3'
+gem 'sqlite3'
+
+
+
# Bundle edge Rails instead:
# gem 'rails', :git => 'git://github.com/rails/rails.git'
group :production do
+
+ gem "heroku"
gem 'pg'
end
# Gems used only for assets and not required
# in production environments by default.
group :assets do
+
+ gem 'less-rails'
+ gem 'therubyracer'
+ gem 'libv8', '3.3.10.4'
+
gem 'sass-rails', '~> 3.2.3'
gem 'coffee-rails', '~> 3.2.1'
@@ -53,7 +66,7 @@ group :development, :test do
gem 'guard-jasmine'
gem 'guard-coffeescript'
gem 'guard-livereload'
- gem 'sqlite3'
+
gem 'rb-inotify', '~> 0.8.8'
end
View
@@ -1,31 +1,31 @@
GEM
remote: https://rubygems.org/
specs:
- actionmailer (3.2.2)
- actionpack (= 3.2.2)
- mail (~> 2.4.0)
- actionpack (3.2.2)
- activemodel (= 3.2.2)
- activesupport (= 3.2.2)
+ actionmailer (3.2.3)
+ actionpack (= 3.2.3)
+ mail (~> 2.4.4)
+ actionpack (3.2.3)
+ activemodel (= 3.2.3)
+ activesupport (= 3.2.3)
builder (~> 3.0.0)
erubis (~> 2.7.0)
journey (~> 1.0.1)
rack (~> 1.4.0)
- rack-cache (~> 1.1)
+ rack-cache (~> 1.2)
rack-test (~> 0.6.1)
sprockets (~> 2.1.2)
- activemodel (3.2.2)
- activesupport (= 3.2.2)
+ activemodel (3.2.3)
+ activesupport (= 3.2.3)
builder (~> 3.0.0)
- activerecord (3.2.2)
- activemodel (= 3.2.2)
- activesupport (= 3.2.2)
+ activerecord (3.2.3)
+ activemodel (= 3.2.3)
+ activesupport (= 3.2.3)
arel (~> 3.0.2)
tzinfo (~> 0.3.29)
- activeresource (3.2.2)
- activemodel (= 3.2.2)
- activesupport (= 3.2.2)
- activesupport (3.2.2)
+ activeresource (3.2.3)
+ activemodel (= 3.2.3)
+ activesupport (= 3.2.3)
+ activesupport (3.2.3)
i18n (~> 0.6)
multi_json (~> 1.0)
addressable (2.3.2)
@@ -45,32 +45,41 @@ GEM
daemons (1.1.9)
diff-lcs (1.1.3)
ejs (1.0.0)
- em-websocket (0.3.6)
+ em-websocket (0.3.8)
addressable (>= 2.1.1)
eventmachine (>= 0.12.9)
erubis (2.7.0)
eventmachine (1.0.0)
+ excon (0.16.7)
execjs (1.4.0)
multi_json (~> 1.0)
ffi (1.1.5)
- guard (1.5.2)
+ guard (1.5.3)
listen (>= 0.4.2)
lumberjack (>= 1.0.2)
pry (>= 0.9.10)
thor (>= 0.14.6)
- guard-coffeescript (0.5.4)
+ guard-coffeescript (1.2.1)
coffee-script (>= 2.2.0)
- guard (>= 0.8.3)
+ guard (>= 1.1.0)
guard-jasmine (1.9.3)
childprocess
guard (>= 1.1.0)
multi_json
thor
- guard-livereload (0.4.2)
+ guard-livereload (1.1.0)
em-websocket (>= 0.2.0)
- guard (>= 0.10.0)
+ guard (>= 1.5.0)
multi_json (~> 1.0)
haml (3.1.7)
+ heroku (2.33.0)
+ heroku-api (~> 0.3.5)
+ launchy (>= 0.3.2)
+ netrc (~> 0.7.7)
+ rest-client (~> 1.6.1)
+ rubyzip
+ heroku-api (0.3.6)
+ excon (~> 0.16.7)
hike (1.2.1)
i18n (0.6.1)
jasmine (1.2.1)
@@ -87,9 +96,11 @@ GEM
railties (>= 3.1.0, < 5.0)
thor (~> 0.14)
json (1.7.5)
+ launchy (2.1.2)
+ addressable (~> 2.3)
less (2.2.2)
commonjs (~> 0.2.6)
- less-rails (2.2.5)
+ less-rails (2.2.6)
actionpack (>= 3.1)
less (~> 2.2.0)
libv8 (3.3.10.4)
@@ -103,7 +114,8 @@ GEM
treetop (~> 1.4.8)
method_source (0.8.1)
mime-types (1.19)
- multi_json (1.3.6)
+ multi_json (1.3.7)
+ netrc (0.7.7)
pg (0.14.1)
polyglot (0.3.3)
pry (0.9.10)
@@ -117,21 +129,21 @@ GEM
rack
rack-test (0.6.2)
rack (>= 1.0)
- rails (3.2.2)
- actionmailer (= 3.2.2)
- actionpack (= 3.2.2)
- activerecord (= 3.2.2)
- activeresource (= 3.2.2)
- activesupport (= 3.2.2)
+ rails (3.2.3)
+ actionmailer (= 3.2.3)
+ actionpack (= 3.2.3)
+ activerecord (= 3.2.3)
+ activeresource (= 3.2.3)
+ activesupport (= 3.2.3)
bundler (~> 1.0)
- railties (= 3.2.2)
+ railties (= 3.2.3)
rails-backbone (0.7.0)
coffee-script (~> 2.2.0)
ejs (~> 1.0.0)
railties (>= 3.1.0)
- railties (3.2.2)
- actionpack (= 3.2.2)
- activesupport (= 3.2.2)
+ railties (3.2.3)
+ actionpack (= 3.2.3)
+ activesupport (= 3.2.3)
rack-ssl (~> 1.3.2)
rake (>= 0.8.7)
rdoc (~> 3.4)
@@ -141,6 +153,8 @@ GEM
ffi (>= 0.5.0)
rdoc (3.12)
json (~> 1.4)
+ rest-client (1.6.7)
+ mime-types (>= 1.16)
rspec (2.11.0)
rspec-core (~> 2.11.0)
rspec-expectations (~> 2.11.0)
@@ -150,12 +164,12 @@ GEM
diff-lcs (~> 1.1.3)
rspec-mocks (2.11.3)
rubyzip (0.9.9)
- sass (3.2.1)
+ sass (3.2.2)
sass-rails (3.2.5)
railties (~> 3.2.0)
sass (>= 3.1.10)
tilt (~> 1.3)
- selenium-webdriver (2.25.0)
+ selenium-webdriver (2.26.0)
childprocess (>= 0.2.5)
libwebsocket (~> 0.1.3)
multi_json (~> 1.0)
@@ -177,11 +191,10 @@ GEM
treetop (1.4.12)
polyglot
polyglot (>= 0.3.1)
- twitter-bootstrap-rails (2.1.4)
+ twitter-bootstrap-rails (2.1.6)
actionpack (>= 3.1)
- less-rails (~> 2.2.3)
+ execjs
railties (>= 3.1)
- therubyracer (>= 0.10.2)
tzinfo (0.3.34)
uglifier (1.3.0)
execjs (>= 0.3.0)
@@ -196,15 +209,19 @@ DEPENDENCIES
guard-coffeescript
guard-jasmine
guard-livereload
+ heroku
jasmine
jasminerice
jquery-rails
+ less-rails
+ libv8 (= 3.3.10.4)
pg
- rails (= 3.2.2)
+ rails (= 3.2.3)
rails-backbone (= 0.7.0)
rb-inotify (~> 0.8.8)
sass-rails (~> 3.2.3)
sqlite3
+ therubyracer
thin
twitter-bootstrap-rails
uglifier (>= 1.0.3)
View
@@ -1,6 +1,13 @@
source 'https://rubygems.org'
-gem 'rails', '3.2.2'
+#ruby '1.9.3'
+
+#gem 'bundler', '1.2.0.pre'
+gem 'rails', '3.2.3'
+gem 'sqlite3'
+gem "heroku"
+
+
# Bundle edge Rails instead:
# gem 'rails', :git => 'git://github.com/rails/rails.git'
@@ -13,6 +20,11 @@ end
# Gems used only for assets and not required
# in production environments by default.
group :assets do
+
+ gem 'less-rails'
+ gem 'therubyracer'
+ gem 'libv8', '3.3.10.4'
+
gem 'sass-rails', '~> 3.2.3'
gem 'coffee-rails', '~> 3.2.1'
@@ -52,7 +64,7 @@ group :development, :test do
gem 'guard-jasmine'
gem 'guard-coffeescript'
gem 'guard-livereload'
- gem 'sqlite3'
+
gem 'rb-inotify', '~> 0.8.8'
end
View
@@ -0,0 +1,16 @@
+#!/usr/bin/env ruby
+#
+# This file was generated by Bundler.
+#
+# The application 'autospec' is installed as part of a gem, and
+# this file is here to facilitate running it.
+#
+
+require 'pathname'
+ENV['BUNDLE_GEMFILE'] ||= File.expand_path("../../Gemfile",
+ Pathname.new(__FILE__).realpath)
+
+require 'rubygems'
+require 'bundler/setup'
+
+load Gem.bin_path('rspec-core', 'autospec')
View
@@ -0,0 +1,16 @@
+#!/usr/bin/env ruby
+#
+# This file was generated by Bundler.
+#
+# The application 'erubis' is installed as part of a gem, and
+# this file is here to facilitate running it.
+#
+
+require 'pathname'
+ENV['BUNDLE_GEMFILE'] ||= File.expand_path("../../Gemfile",
+ Pathname.new(__FILE__).realpath)
+
+require 'rubygems'
+require 'bundler/setup'
+
+load Gem.bin_path('erubis', 'erubis')
View
@@ -0,0 +1,16 @@
+#!/usr/bin/env ruby
+#
+# This file was generated by Bundler.
+#
+# The application 'haml' is installed as part of a gem, and
+# this file is here to facilitate running it.
+#
+
+require 'pathname'
+ENV['BUNDLE_GEMFILE'] ||= File.expand_path("../../Gemfile",
+ Pathname.new(__FILE__).realpath)
+
+require 'rubygems'
+require 'bundler/setup'
+
+load Gem.bin_path('haml', 'haml')
View
@@ -0,0 +1,16 @@
+#!/usr/bin/env ruby
+#
+# This file was generated by Bundler.
+#
+# The application 'heroku' is installed as part of a gem, and
+# this file is here to facilitate running it.
+#
+
+require 'pathname'
+ENV['BUNDLE_GEMFILE'] ||= File.expand_path("../../Gemfile",
+ Pathname.new(__FILE__).realpath)
+
+require 'rubygems'
+require 'bundler/setup'
+
+load Gem.bin_path('heroku', 'heroku')
View
@@ -0,0 +1,16 @@
+#!/usr/bin/env ruby
+#
+# This file was generated by Bundler.
+#
+# The application 'html2haml' is installed as part of a gem, and
+# this file is here to facilitate running it.
+#
+
+require 'pathname'
+ENV['BUNDLE_GEMFILE'] ||= File.expand_path("../../Gemfile",
+ Pathname.new(__FILE__).realpath)
+
+require 'rubygems'
+require 'bundler/setup'
+
+load Gem.bin_path('haml', 'html2haml')
View
@@ -0,0 +1,16 @@
+#!/usr/bin/env ruby
+#
+# This file was generated by Bundler.
+#
+# The application 'htmldiff' is installed as part of a gem, and
+# this file is here to facilitate running it.
+#
+
+require 'pathname'
+ENV['BUNDLE_GEMFILE'] ||= File.expand_path("../../Gemfile",
+ Pathname.new(__FILE__).realpath)
+
+require 'rubygems'
+require 'bundler/setup'
+
+load Gem.bin_path('diff-lcs', 'htmldiff')
Oops, something went wrong.

0 comments on commit 0c2a166

Please sign in to comment.