Permalink
Browse files

remove jeweler

  • Loading branch information...
1 parent 8201062 commit 842c96b5e2006448a648ab822439bd1b059d02b3 @igrigorik igrigorik committed Oct 30, 2010
Showing with 29 additions and 113 deletions.
  1. +9 −10 Gemfile
  2. +2 −27 Rakefile
  3. +0 −1 VERSION
  4. +17 −74 em-synchrony.gemspec
  5. +1 −1 lib/em-synchrony.rb
View
19 Gemfile
@@ -1,16 +1,15 @@
source :gemcutter
gem 'eventmachine', :git => 'git://github.com/eventmachine/eventmachine.git'
-gem 'em-http-request'
-
-gem 'remcached'
-gem 'em-mongo'
-gem 'bson_ext'
-gem 'mysqlplus'
-gem 'em-mysqlplus'
-gem 'em-redis'
-gem 'mongo'
group :development do
gem 'rspec', '~> 2.0.0'
-end
+ gem 'em-http-request'
+ gem 'remcached'
+ gem 'em-mongo'
+ gem 'bson_ext'
+ gem 'mysqlplus'
+ gem 'em-mysqlplus'
+ gem 'em-redis'
+ gem 'mongo'
+end
View
@@ -1,29 +1,4 @@
-require 'rubygems'
require 'bundler'
-Bundler.setup
-
-require 'rake'
-require 'rspec/core/rake_task'
-
-RSpec::Core::RakeTask.new(:spec) do |spec|
- spec.pattern = "spec/**/*_spec.rb"
-end
-begin
- require "jeweler"
- Jeweler::Tasks.new do |gemspec|
- gemspec.name = "em-synchrony"
- gemspec.summary = "Fiber aware EventMachine libraries"
- gemspec.description = gemspec.summary
- gemspec.email = "ilya@igvita.com"
- gemspec.homepage = "http://github.com/igrigorik/em-synchrony"
- gemspec.authors = ["Ilya Grigorik"]
- gemspec.required_ruby_version = ">= 1.9"
- gemspec.add_dependency("eventmachine", ">= 0.12.9")
- gemspec.rubyforge_project = "em-synchrony"
- end
-
- Jeweler::GemcutterTasks.new
-rescue LoadError
- puts "Jeweler not available: gem install jeweler"
-end
+Bundler.setup
+Bundler::GemHelper.install_tasks
View
@@ -1 +0,0 @@
-0.1.5
View
@@ -1,80 +1,23 @@
-# Generated by jeweler
-# DO NOT EDIT THIS FILE DIRECTLY
-# Instead, edit Jeweler::Tasks in Rakefile, and run the gemspec command
# -*- encoding: utf-8 -*-
+$:.push File.expand_path("../lib", __FILE__)
Gem::Specification.new do |s|
- s.name = %q{em-synchrony}
- s.version = "0.1.5"
+ s.name = "em-synchrony"
+ s.version = "0.2.0"
+ s.platform = Gem::Platform::RUBY
+ s.authors = ["Ilya Grigorik"]
+ s.email = ["ilya@igvita.com"]
+ s.homepage = "http://github.com/igrigorik/em-synchrony"
+ s.summary = %q{Fiber aware EventMachine libraries}
+ s.description = s.summary
- s.required_rubygems_version = Gem::Requirement.new(">= 0") if s.respond_to? :required_rubygems_version=
- s.authors = ["Ilya Grigorik"]
- s.date = %q{2010-06-19}
- s.description = %q{Fiber aware EventMachine libraries}
- s.email = %q{ilya@igvita.com}
- s.extra_rdoc_files = [
- "README.md"
- ]
- s.files = [
- "README.md",
- "Rakefile",
- "VERSION",
- "examples/all.rb",
- "examples/bitly.rb",
- "lib/em-synchrony.rb",
- "lib/em-synchrony/connection_pool.rb",
- "lib/em-synchrony/em-bitly.rb",
- "lib/em-synchrony/em-http.rb",
- "lib/em-synchrony/em-jack.rb",
- "lib/em-synchrony/em-mongo.rb",
- "lib/em-synchrony/em-multi.rb",
- "lib/em-synchrony/em-mysqlplus.rb",
- "lib/em-synchrony/em-remcached.rb",
- "lib/em-synchrony/iterator.rb",
- "spec/beanstalk_spec.rb",
- "spec/connection_pool_spec.rb",
- "spec/helper/all.rb",
- "spec/helper/stub-http-server.rb",
- "spec/helper/tolerance_matcher.rb",
- "spec/http_spec.rb",
- "spec/iterator_spec.rb",
- "spec/mongo_spec.rb",
- "spec/mysqlplus_spec.rb",
- "spec/remcached_spec.rb"
- ]
- s.homepage = %q{http://github.com/igrigorik/em-synchrony}
- s.rdoc_options = ["--charset=UTF-8"]
- s.require_paths = ["lib"]
- s.required_ruby_version = Gem::Requirement.new(">= 1.9")
- s.rubyforge_project = %q{em-synchrony}
- s.rubygems_version = %q{1.3.6}
- s.summary = %q{Fiber aware EventMachine libraries}
- s.test_files = [
- "spec/beanstalk_spec.rb",
- "spec/connection_pool_spec.rb",
- "spec/helper/all.rb",
- "spec/helper/stub-http-server.rb",
- "spec/helper/tolerance_matcher.rb",
- "spec/http_spec.rb",
- "spec/iterator_spec.rb",
- "spec/mongo_spec.rb",
- "spec/mysqlplus_spec.rb",
- "spec/remcached_spec.rb",
- "examples/all.rb",
- "examples/bitly.rb"
- ]
-
- if s.respond_to? :specification_version then
- current_version = Gem::Specification::CURRENT_SPECIFICATION_VERSION
- s.specification_version = 3
+ s.rubyforge_project = "em-synchrony"
- if Gem::Version.new(Gem::RubyGemsVersion) >= Gem::Version.new('1.2.0') then
- s.add_runtime_dependency(%q<eventmachine>, [">= 0.12.9"])
- else
- s.add_dependency(%q<eventmachine>, [">= 0.12.9"])
- end
- else
- s.add_dependency(%q<eventmachine>, [">= 0.12.9"])
- end
-end
+ s.required_ruby_version = Gem::Requirement.new(">= 1.9")
+ s.add_runtime_dependency("eventmachine", [">= 0.12.9"])
+ s.files = `git ls-files`.split("\n")
+ s.test_files = `git ls-files -- {test,spec,features}/*`.split("\n")
+ s.executables = `git ls-files -- bin/*`.split("\n").map{ |f| File.basename(f) }
+ s.require_paths = ["lib"]
+end
View
@@ -12,7 +12,7 @@
require "em-synchrony/em-multi"
require "em-synchrony/tcpsocket"
require "em-synchrony/connection_pool"
-require "em-synchrony/iterator" unless EventMachine::VERSION == '0.12.10'
+require "em-synchrony/iterator" unless EventMachine::VERSION >= '0.12.10'
module EventMachine

0 comments on commit 842c96b

Please sign in to comment.