New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Update to use newer node path code #11

Closed
nrkn opened this Issue May 25, 2017 · 1 comment

Comments

Projects
None yet
2 participants
@nrkn
Copy link

nrkn commented May 25, 2017

The version of path this uses is very old - many things won't work, eg my code uses path.posix because it needs to process posix paths even when running on windows, but it's missing in this version so you get undefined error in browser. Also path.parse and etc

I'd be happy to do a PR but only if it's welcome and likely to actually get merged - hasn't been any activity here in four years

Alternately is there a way to override core things like path in browserify? I read the manual etc but couldn't find anything. May have missed it.

@goto-bus-stop

This comment has been minimized.

Copy link
Member

goto-bus-stop commented Jun 6, 2018

#12 updated to Node 8. i'll release soon after porting some more tests.

Alternately is there a way to override core things like path in browserify? I read the manual etc but couldn't find anything. May have missed it.

you can use the --require flag with an alias to do this sort of thing:

browserify --require ./my-path-polyfill:path
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment