Skip to content
This repository has been archived by the owner. It is now read-only.

unable to install on Mac #80

Closed
siwan05 opened this issue May 15, 2017 · 11 comments

Comments

10 participants
@siwan05
Copy link

commented May 15, 2017

Hey guys,
I'm trying to get this running in Chrome on my Mac. I simply installed the extension, downloaded the package browserpass-darwinx64 and when trying to execute the install script I first get to select my browser and then I get the following error:
"
Installing Chrome host config
cp: /X/files/browserpass-darwinx64/chrome-policy.json: No such file or directory
"
From what I can see that file is not part of the package, have I missed some step that I should have done before running the install script?

Cheers,
siwan

@dannyvankooten dannyvankooten added the bug label May 15, 2017

@dannyvankooten

This comment has been minimized.

Copy link
Collaborator

commented May 15, 2017

Hey @siwan05,

You're right, looks like the make target is broken for building the release package, the chrome-policy.json file should be there but is missing. Nothing you did wrong, it's a bug.

@benni336

This comment has been minimized.

Copy link

commented Jun 6, 2017

So what does it mean now. I wanted to install it with vivaldi. This leads to the same bug. Any shortcut/workaround?

@benni336

This comment has been minimized.

Copy link

commented Jun 6, 2017

blame me for stupidity :(
Everything is ok for installation. Just use one of the release versions here:
https://github.com/dannyvankooten/browserpass/releases/

@jeffutter

This comment has been minimized.

Copy link

commented Jun 8, 2017

I'm using a release version (1.0.4) and get this error for Chrome on MacOS.

@dgrusemann

This comment has been minimized.

Copy link

commented Jun 15, 2017

I am also getting that error using the latest release version (1.0.6).
Was able to fix the error by using and renaming the file from the source package.

@compuguy

This comment has been minimized.

Copy link

commented Jul 20, 2017

@dgrusemann I'm guessing you just renamed the chrome-host.json file to chrome-policy.json?

@rafi

This comment has been minimized.

Copy link

commented Jul 21, 2017

I solved this with mv policy.json chrome-policy.json

@dgrusemann

This comment has been minimized.

Copy link

commented Jul 22, 2017

Yes, it was done using the solution @rafi mentioned.

@juanibiapina

This comment has been minimized.

Copy link

commented Aug 16, 2017

Release 1.0.6 also doesn't work with same error on osx.

@inferiorhumanorgans

This comment has been minimized.

Copy link
Contributor

commented Aug 17, 2017

@rafi's fix doesn't work for me as there's no policy.json in 1.0.6.

@maximbaz

This comment has been minimized.

Copy link
Member

commented Sep 14, 2017

This has been fixed in master thanks to #114.

@maximbaz maximbaz closed this Sep 14, 2017

Sign up for free to subscribe to this conversation on GitHub. Already have an account? Sign in.
You can’t perform that action at this time.