Permalink
Browse files

GitHub style guide

  • Loading branch information...
1 parent 915b1a9 commit b7d30c98729d4638474970210d3868d20e38a8e8 @laserlemon laserlemon committed Mar 27, 2012
Showing with 17 additions and 18 deletions.
  1. +0 −1 Gemfile
  2. +1 −1 LICENSE
  3. +3 −2 Rakefile
  4. +11 −11 memdash.gemspec
  5. +1 −2 spec/memdash_spec.rb
  6. +1 −1 spec/spec_helper.rb
View
@@ -1,4 +1,3 @@
source 'https://rubygems.org'
-# Specify your gem's dependencies in memdash.gemspec
gemspec
View
@@ -19,4 +19,4 @@ MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND
NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT HOLDERS BE
LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION
OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION
-WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.
+WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.
View
@@ -1,6 +1,7 @@
#!/usr/bin/env rake
-require "bundler/gem_tasks"
-require "rspec/core/rake_task"
+
+require 'bundler/gem_tasks'
+require 'rspec/core/rake_task'
RSpec::Core::RakeTask.new(:spec)
View
@@ -1,21 +1,21 @@
# encoding: utf-8
Gem::Specification.new do |gem|
- gem.name = "memdash"
- gem.version = "0.0.1"
+ gem.name = 'memdash'
+ gem.version = '0.0.1'
- gem.authors = ["Brian Ryckbost", "Steve Richert"]
- gem.email = ["bryckbost@gmail.com", "steve.richert@gmail.com"]
- gem.description = "Gain insight into your memcached servers"
- gem.summary = "Gain insight into your memcached servers"
- gem.homepage = "https://github.com/bryckbost/memdash"
+ gem.authors = ['Brian Ryckbost', 'Steve Richert']
+ gem.email = ['bryckbost@gmail.com', 'steve.richert@gmail.com']
+ gem.description = 'Gain insight into your memcached servers'
+ gem.summary = 'Gain insight into your memcached servers'
+ gem.homepage = 'https://github.com/bryckbost/memdash'
- gem.add_dependency "dalli", "~> 1.0"
+ gem.add_dependency 'dalli', '~> 1.0'
- gem.add_development_dependency "rake", ">= 0.8.7"
- gem.add_development_dependency "rspec", "~> 2.0"
+ gem.add_development_dependency 'rake', '>= 0.8.7'
+ gem.add_development_dependency 'rspec', '~> 2.0'
gem.files = `git ls-files`.split($\)
gem.test_files = gem.files.grep(/^spec\//)
- gem.require_paths = ["lib"]
+ gem.require_paths = ['lib']
end
View
@@ -1,5 +1,4 @@
require 'spec_helper'
describe Memdash do
-
-end
+end
View
@@ -1 +1 @@
-require 'memdash'
+require 'memdash'

0 comments on commit b7d30c9

Please sign in to comment.