Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

Already on GitHub? Sign in to your account

Rails 3.1 compatibility - Encoding::CompatibilityError - Is this project still maintained? #36

Open
fabn opened this Issue Sep 8, 2011 · 4 comments

Comments

Projects
None yet
3 participants

fabn commented Sep 8, 2011

I used this a long time ago when still using Rails 2.3.x, and I liked it very much. Now I'd like to use it on my new Rails 3.1 project, but I see no updates, it's more than one year that Rails 3.0 is out and the master branch still points to 2.3.x version.

I've tried it (rails3 branch) in a 3.1 (with Ruby 1.9.2) project and I get this error:

Encoding::CompatibilityError (incompatible character encodings: UTF-8 and US-ASCII):

I saw that is the same error of #7 which is still pending.

Is there any chance that this project will be updated to support recent versions of Rails?

Collaborator

knzconnor commented Sep 10, 2011

I had grand plans to update eveythig after getting commit, but got super busy. If you make a fresh fork off of master and send pull requests, I'll merge them in. Branch per feature/set of changes, and with tests, preferably, but at this point it'd be nice to even see it running on 3x

Collaborator

knzconnor commented Oct 13, 2011

There is a pull request that needs a little tweaking, that I'll gladly merge in. As I mentioned, feel free to submit pull requests and I'll merge them.

pboling commented Sep 5, 2012

I am also running into this error in my fork, rack-insight. Looking into a fix.

pboling commented Sep 6, 2012

For me I was able to fix it by copying the fix that was applied to Rack::Bug awhile ago:

pboling/rack-insight@e1b7b3b

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment