Permalink
Browse files

Lockdown all dependency versions

  • Loading branch information...
1 parent 87fe1ba commit 078bf58c7d42b8d74c090aa4b6cc3060ea3baf3b @schof schof committed Oct 23, 2011
Showing with 96 additions and 107 deletions.
  1. +83 −94 Gemfile.lock
  2. +13 −13 core/spree_core.gemspec
View
@@ -15,19 +15,19 @@ PATH
cancan (>= 1.3.3)
spree_core (= 0.30.2)
spree_core (0.30.2)
- activemerchant (>= 1.7.1)
- acts_as_list (>= 0.1.2)
- faker (>= 0.3.1)
- highline (>= 1.5.1)
- jquery-rails (>= 0.2.2)
- paperclip (>= 2.3.1.1)
- rails (~> 3.0.4)
- rd_awesome_nested_set (>= 1.4.4)
+ activemerchant (= 1.7.1)
+ acts_as_list (= 0.1.2)
+ faker (= 0.3.1)
+ highline (= 1.5.1)
+ jquery-rails (= 0.2.2)
+ paperclip (= 2.3.1.1)
+ rails (= 3.0.4)
+ rd_awesome_nested_set (= 1.4.4)
rd_resource_controller
- rd_searchlogic (>= 3.0.0.rc3)
- rd_unobtrusive_date_picker (>= 0.1.0)
- state_machine (>= 0.9.4)
- stringex (>= 1.0.3)
+ rd_searchlogic (= 3.0.0.rc3)
+ rd_unobtrusive_date_picker (= 0.1.0)
+ state_machine (= 0.9.4)
+ stringex (= 1.0.3)
will_paginate (= 3.0.pre)
spree_dash (0.30.2)
spree_core (= 0.30.2)
@@ -40,44 +40,37 @@ GEM
remote: http://rubygems.org/
specs:
abstract (1.0.0)
- actionmailer (3.0.8)
- actionpack (= 3.0.8)
- mail (~> 2.2.19)
- actionpack (3.0.8)
- activemodel (= 3.0.8)
- activesupport (= 3.0.8)
+ actionmailer (3.0.4)
+ actionpack (= 3.0.4)
+ mail (~> 2.2.15)
+ actionpack (3.0.4)
+ activemodel (= 3.0.4)
+ activesupport (= 3.0.4)
builder (~> 2.1.2)
erubis (~> 2.6.6)
- i18n (~> 0.5.0)
+ i18n (~> 0.4)
rack (~> 1.2.1)
- rack-mount (~> 0.6.14)
+ rack-mount (~> 0.6.13)
rack-test (~> 0.5.7)
tzinfo (~> 0.3.23)
- active_utils (1.0.1)
- activesupport (>= 2.3.11)
- i18n
- activemerchant (1.18.1)
- active_utils (>= 1.0.1)
- activesupport (>= 2.3.11)
+ activemerchant (1.7.1)
+ activesupport (>= 2.3.2)
braintree (>= 2.0.0)
builder (>= 2.0.0)
- i18n
- json (>= 1.5.1)
- money
- activemodel (3.0.8)
- activesupport (= 3.0.8)
+ activemodel (3.0.4)
+ activesupport (= 3.0.4)
builder (~> 2.1.2)
- i18n (~> 0.5.0)
- activerecord (3.0.8)
- activemodel (= 3.0.8)
- activesupport (= 3.0.8)
- arel (~> 2.0.10)
+ i18n (~> 0.4)
+ activerecord (3.0.4)
+ activemodel (= 3.0.4)
+ activesupport (= 3.0.4)
+ arel (~> 2.0.2)
tzinfo (~> 0.3.23)
- activeresource (3.0.8)
- activemodel (= 3.0.8)
- activesupport (= 3.0.8)
- activesupport (3.0.8)
- acts_as_list (0.1.4)
+ activeresource (3.0.4)
+ activemodel (= 3.0.4)
+ activesupport (= 3.0.4)
+ activesupport (3.0.4)
+ acts_as_list (0.1.2)
arel (2.0.10)
authlogic (2.1.6)
activesupport
@@ -92,74 +85,68 @@ GEM
rack (>= 1.0.0)
rack-test (>= 0.5.4)
selenium-webdriver (>= 0.0.3)
- cocaine (0.2.0)
- columnize (0.3.1)
- cucumber (0.8.5)
- builder (~> 2.1.2)
- diff-lcs (~> 1.1.2)
- gherkin (~> 2.1.4)
- json_pure (~> 1.4.3)
- term-ansicolor (~> 1.0.4)
+ childprocess (0.2.2)
+ ffi (~> 1.0.6)
+ columnize (0.3.4)
+ cucumber (1.1.0)
+ builder (>= 2.1.2)
+ diff-lcs (>= 1.1.2)
+ gherkin (~> 2.5.0)
+ json (>= 1.4.6)
+ term-ansicolor (>= 1.0.6)
cucumber-rails (0.3.2)
cucumber (>= 0.8.0)
- culerity (0.2.12)
+ culerity (0.2.15)
database_cleaner (0.5.2)
- diff-lcs (1.1.2)
+ diff-lcs (1.1.3)
erubis (2.6.6)
abstract (>= 1.0.0)
- fabrication (0.7.0)
- faker (1.0.1)
- i18n (~> 0.4)
- ffi (0.6.3)
- rake (>= 0.8.7)
- gherkin (2.1.5)
- trollop (~> 1.16.2)
- highline (1.6.2)
- i18n (0.5.0)
- jquery-rails (1.0.16)
- railties (~> 3.0)
- thor (~> 0.14)
+ fabrication (1.2.0)
+ faker (0.3.1)
+ ffi (1.0.9)
+ gherkin (2.5.4)
+ json (>= 1.4.6)
+ highline (1.5.1)
+ i18n (0.6.0)
+ jquery-rails (0.2.2)
+ rails (~> 3.0)
json (1.6.1)
- json_pure (1.4.6)
- linecache (0.43)
+ json_pure (1.6.1)
+ linecache (0.46)
+ rbx-require-relative (> 0.0.4)
mail (2.2.19)
activesupport (>= 2.3.6)
i18n (>= 0.4.0)
mime-types (~> 1.16)
treetop (~> 1.4.8)
mime-types (1.16)
- money (3.7.1)
- i18n (~> 0.4)
- nokogiri (1.4.3.1)
- paperclip (2.4.5)
- activerecord (>= 2.3.0)
- activesupport (>= 2.3.2)
- cocaine (>= 0.0.2)
- mime-types
+ nokogiri (1.5.0)
+ paperclip (2.3.1.1)
polyglot (0.3.2)
rack (1.2.4)
rack-mount (0.6.14)
rack (>= 1.0.0)
rack-test (0.5.7)
rack (>= 1.0)
- rails (3.0.8)
- actionmailer (= 3.0.8)
- actionpack (= 3.0.8)
- activerecord (= 3.0.8)
- activeresource (= 3.0.8)
- activesupport (= 3.0.8)
+ rails (3.0.4)
+ actionmailer (= 3.0.4)
+ actionpack (= 3.0.4)
+ activerecord (= 3.0.4)
+ activeresource (= 3.0.4)
+ activesupport (= 3.0.4)
bundler (~> 1.0)
- railties (= 3.0.8)
- railties (3.0.8)
- actionpack (= 3.0.8)
- activesupport (= 3.0.8)
+ railties (= 3.0.4)
+ railties (3.0.4)
+ actionpack (= 3.0.4)
+ activesupport (= 3.0.4)
rake (>= 0.8.7)
thor (~> 0.14.4)
rake (0.9.2.2)
+ rbx-require-relative (0.0.5)
rd_awesome_nested_set (1.4.4)
activerecord (>= 1.1)
rd_resource_controller (1.0.1)
- rd_searchlogic (3.0.1)
+ rd_searchlogic (3.0.0.rc3)
activerecord (>= 3.0.0)
rd_unobtrusive_date_picker (0.1.0)
rdoc (2.2.0)
@@ -175,25 +162,27 @@ GEM
rspec-expectations (~> 2.0.1)
rspec-rails (2.0.1)
rspec (~> 2.0.0)
- ruby-debug (0.10.3)
+ ruby-debug (0.10.4)
columnize (>= 0.1)
- ruby-debug-base (~> 0.10.3.0)
- ruby-debug-base (0.10.3)
+ ruby-debug-base (~> 0.10.4.0)
+ ruby-debug-base (0.10.4)
linecache (>= 0.3)
rubyzip (0.9.4)
- selenium-webdriver (0.0.28)
- ffi (>= 0.6.1)
+ selenium-webdriver (2.9.1)
+ childprocess (>= 0.2.1)
+ ffi (= 1.0.9)
json_pure
rubyzip
- sqlite3-ruby (1.3.1)
- state_machine (1.0.2)
- stringex (1.3.0)
- term-ansicolor (1.0.5)
+ sqlite3 (1.3.4)
+ sqlite3-ruby (1.3.3)
+ sqlite3 (>= 1.3.3)
+ state_machine (0.9.4)
+ stringex (1.0.3)
+ term-ansicolor (1.0.7)
thor (0.14.6)
treetop (1.4.10)
polyglot
polyglot (>= 0.3.1)
- trollop (1.16.2)
tzinfo (0.3.30)
will_paginate (3.0.pre)
View
@@ -17,20 +17,20 @@ Gem::Specification.new do |s|
s.require_path = 'lib'
s.requirements << 'none'
- s.add_dependency('acts_as_list', '>= 0.1.2')
- s.add_dependency('rd_awesome_nested_set', '>= 1.4.4')
- s.add_dependency('rd_unobtrusive_date_picker', '>= 0.1.0')
+ s.add_dependency('acts_as_list', '0.1.2')
+ s.add_dependency('rd_awesome_nested_set', '1.4.4')
+ s.add_dependency('rd_unobtrusive_date_picker', '0.1.0')
- s.add_dependency('highline', '>= 1.5.1')
+ s.add_dependency('highline', '1.5.1')
#s.add_dependency('less', '>= 1.2.20')
- s.add_dependency('stringex', '>= 1.0.3')
- s.add_dependency('state_machine', '>= 0.9.4')
- s.add_dependency('faker', '>= 0.3.1')
- s.add_dependency('paperclip', '>= 2.3.1.1')
+ s.add_dependency('stringex', '1.0.3')
+ s.add_dependency('state_machine', '0.9.4')
+ s.add_dependency('faker', '0.3.1')
+ s.add_dependency('paperclip', '2.3.1.1')
s.add_dependency('rd_resource_controller')
- s.add_dependency('rd_searchlogic', '>= 3.0.0.rc3')
- s.add_dependency('activemerchant', '>= 1.7.1')
- s.add_dependency('will_paginate', '= 3.0.pre')
- s.add_dependency('rails', '~> 3.0.4')
- s.add_dependency('jquery-rails', '>= 0.2.2')
+ s.add_dependency('rd_searchlogic', '3.0.0.rc3')
+ s.add_dependency('activemerchant', '1.7.1')
+ s.add_dependency('will_paginate', '3.0.pre')
+ s.add_dependency('rails', '3.0.4')
+ s.add_dependency('jquery-rails', '0.2.2')
end

0 comments on commit 078bf58

Please sign in to comment.