Skip to content
Permalink
Browse files

Lock down autobahn version to < 0.13.0 when used wwith python2.6

  • Loading branch information...
anish committed Mar 16, 2016
1 parent 605ed7b commit 612097f4dfbc3dcc058ddc763a419724878b96c5
Showing with 5 additions and 2 deletions.
  1. +5 −2 master/setup.py
@@ -391,10 +391,13 @@ def define_plugin_entries(groups):
raise RuntimeError(VERSION_MSG)

if sys.version_info[:2] == (2, 6):
# Twisted-15.4.0 doesn't support Python 2.6 anymore
# Twisted-15.4.0 and autobahn 0.13.0 don't support Python 2.6 anymore
twisted_ver = ">= 12.1.0, < 15.4.0"
autobahn_ver = ">= 0.10.2, < 0.13.0"

else:
twisted_ver = ">= 12.1.0"
autobahn_ver = ">= 0.10.2"

try:
# If setuptools is installed, then we'll add setuptools-specific arguments
@@ -412,7 +415,7 @@ def define_plugin_entries(groups):
'sqlalchemy>=0.8.0',
'sqlalchemy-migrate>=0.9',
'python-dateutil>=1.5',
'autobahn >= 0.10.2',
'autobahn ' + autobahn_ver,
]

setup_args['extras_require'] = {

0 comments on commit 612097f

Please sign in to comment.
You can’t perform that action at this time.