New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

log file is scrolling up indefinitely when scroling up #3154

Open
benallard opened this Issue Apr 27, 2017 · 9 comments

Comments

Projects
None yet
5 participants
@benallard
Contributor

benallard commented Apr 27, 2017

When I open a log view. I ghet to see the last lines. When I either press page-up, or try to scroll up, I trigger the loading of the log before my view. This actually scrols up without stopping. The only way to stop it is to click on the scrollbar right to the log, and move the cursor back down. without that, I get to jump up to the top of the logs.

Using chromium, and buildbot 0.9.1.

Just tried with firefox: pressing page-up just jump one line up. and the behavior of the mouse wheel is not very smooth either.

@tardyp

This comment has been minimized.

Show comment
Hide comment
@tardyp

tardyp Apr 27, 2017

Member

Hi Benoit,
I reworked a lot the logviewer and fixed bugs since 0.9.1, notably in the autoloading-on-scroll feature.
Do you reproduce the problem with 0.9.6?

Member

tardyp commented Apr 27, 2017

Hi Benoit,
I reworked a lot the logviewer and fixed bugs since 0.9.1, notably in the autoloading-on-scroll feature.
Do you reproduce the problem with 0.9.6?

@benallard

This comment has been minimized.

Show comment
Hide comment
@benallard

benallard Apr 27, 2017

Contributor

Thanks Pierre, that's an excellent news. Tomorrow is Friday, I'll try to update our master and report back.

Contributor

benallard commented Apr 27, 2017

Thanks Pierre, that's an excellent news. Tomorrow is Friday, I'll try to update our master and report back.

@benallard

This comment has been minimized.

Show comment
Hide comment
@benallard

benallard Apr 28, 2017

Contributor

I'm sorry to report that the behavior is not better with 0.9.6.

Contributor

benallard commented Apr 28, 2017

I'm sorry to report that the behavior is not better with 0.9.6.

@benallard

This comment has been minimized.

Show comment
Hide comment
@benallard

benallard Apr 28, 2017

Contributor

To trigger it, just go to the right page, and scroll up using the mousewheel. the scrolling starts and never ends. It is easier to see on huge logs (90k lines for instance). But it also happens on logs of 600 lines.

Contributor

benallard commented Apr 28, 2017

To trigger it, just go to the right page, and scroll up using the mousewheel. the scrolling starts and never ends. It is easier to see on huge logs (90k lines for instance). But it also happens on logs of 600 lines.

@benallard

This comment has been minimized.

Show comment
Hide comment
@benallard

benallard Apr 28, 2017

Contributor

Same is happening here: https://nine.buildbot.net/#/builders/5/builds/128/steps/4/logs/stdio. With one scroll of the mousewheel, I jump up to line 147 (displayed on top of screen). Once the page is loaded, the same movement on the mousewheel jumps to line 302 (from 314): correct bahavior.

Contributor

benallard commented Apr 28, 2017

Same is happening here: https://nine.buildbot.net/#/builders/5/builds/128/steps/4/logs/stdio. With one scroll of the mousewheel, I jump up to line 147 (displayed on top of screen). Once the page is loaded, the same movement on the mousewheel jumps to line 302 (from 314): correct bahavior.

@krf

This comment has been minimized.

Show comment
Hide comment
@krf

krf Jul 12, 2017

Contributor

I think this ticket needs more attention. The log viewer is a crucial part of Buildbot's web interface, and it currently doesn't work properly as indicated. Still an issue with 0.9.8, fwiw.

Contributor

krf commented Jul 12, 2017

I think this ticket needs more attention. The log viewer is a crucial part of Buildbot's web interface, and it currently doesn't work properly as indicated. Still an issue with 0.9.8, fwiw.

@tardyp

This comment has been minimized.

Show comment
Hide comment
@tardyp

tardyp Jul 12, 2017

Member

I reproduce the problem in 0.9.9.

repharsing:
go to https://nine.buildbot.net/#/builders/5/builds/807/steps/4/logs/stdio
use mouse whell to scroll up once. The screen starts to scroll, butcontinue, as soon as the log continue to load. Once the log has been loaded once, the scrolling works as expected.

I cannot commit I can work on it in a timely fashion. Any help here is appreciated.

Member

tardyp commented Jul 12, 2017

I reproduce the problem in 0.9.9.

repharsing:
go to https://nine.buildbot.net/#/builders/5/builds/807/steps/4/logs/stdio
use mouse whell to scroll up once. The screen starts to scroll, butcontinue, as soon as the log continue to load. Once the log has been loaded once, the scrolling works as expected.

I cannot commit I can work on it in a timely fashion. Any help here is appreciated.

@copumpkin

This comment has been minimized.

Show comment
Hide comment
@copumpkin

copumpkin Aug 29, 2017

This is still biting me too

copumpkin commented Aug 29, 2017

This is still biting me too

@tardyp

This comment has been minimized.

Show comment
Hide comment
@tardyp

tardyp Sep 8, 2017

Member

fixed in #3597

and deployed to nine.buildbot.net. Please test, and I'll make the release

Member

tardyp commented Sep 8, 2017

fixed in #3597

and deployed to nine.buildbot.net. Please test, and I'll make the release

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment