Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

v3.3.0 Not Go Module Compatible #74

Closed
donatj opened this issue Apr 3, 2020 · 3 comments
Closed

v3.3.0 Not Go Module Compatible #74

donatj opened this issue Apr 3, 2020 · 3 comments

Comments

@donatj
Copy link
Contributor

donatj commented Apr 3, 2020

The v3.3.0 release added a go.mod and go.sum but isn't properly versioned so it cannot be used with Go Modules.

Go has a good writeup about how you need to specially handle versions 2 and greater here:

https://blog.golang.org/v2-go-modules

@donatj
Copy link
Contributor Author

donatj commented Sep 9, 2020

This appears fixed? Is it fixed? lol

@yob
Copy link
Contributor

yob commented Sep 10, 2020

oops, thanks for pointing this out.

It's fixed on master, but we haven't tagged a new release so downstream users are still having a bad time (see #77)

@yob
Copy link
Contributor

yob commented Sep 12, 2020

I've published a v.3.4.0 release, which I believe fixes this issue.

I haven't retrospectively changed the earlier 3.x releases that are unusable when go modules are enabled - mutating the tags felt icky and ultimately not really necessary.

Thanks again for highlighting this!

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Labels
None yet
Projects
None yet
Development

No branches or pull requests

2 participants