Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Newer
Older
100644 34 lines (28 sloc) 1.33 kb
08913b7 John Ferlito First commit of Open Source release
johnf authored
1 #
2 # -*- encoding: utf-8 -*-
3 $:.push File.expand_path("../lib", __FILE__)
4 require "ript/version"
5
6 Gem::Specification.new do |s|
7 s.name = "ript"
8 s.version = Ript::VERSION
9 s.platform = Gem::Platform::RUBY
10 s.authors = [ "Lindsay Holmwood" ]
11 s.email = [ "lindsay@bulletproof.net" ]
12 s.homepage = "http://bulletproof.net/"
13 s.summary = %q{DSL for iptables, and tool for incrementally applying firewall rules}
14 s.description = %q{Ript provides a clean Ruby DSL for describing firewall rules, and implements database migrations-like functionality for applying the rules}
15
16 s.rubyforge_project = "ript"
17
18 s.required_ruby_version = ">= 1.9.2"
19 s.required_rubygems_version = ">= 1.3.6"
20
21 s.files = `git ls-files`.split("\n")
22 s.test_files = `git ls-files -- {test,spec,features}/*`.split("\n")
23 s.executables = `git ls-files -- bin/*`.split("\n").map{ |f| File.basename(f) }
24 s.require_paths = ["lib"]
25
26 #s.add_runtime_dependency "colorize", ">= 0"
27 s.add_development_dependency "rake", ">= 0"
28 s.add_development_dependency "rspec", ">= 0"
29 s.add_development_dependency "cucumber", ">= 1.1.9"
30 s.add_development_dependency "aruba", ">= 0"
31 s.add_development_dependency "colorize", ">= 0"
32 s.add_development_dependency "fpm", ">= 0.4.5"
33 end
Something went wrong with that request. Please try again.