Permalink
Fetching contributors…
Cannot retrieve contributors at this time
38 lines (33 sloc) 914 Bytes
.container.guide
%h2 How to use Bundler with RubyMotion
.contents
.bullet
.description
If you don't have a RubyMotion app yet, generate one.
:code
$ motion create myapp
$ cd myapp
.bullet
.description
You'll need to create a Gemfile. Here we're using bubblewrap.
:code
# lang: ruby
gem 'bubble-wrap'
.bullet
.description
Then, set up your Rakefile to require your bundled gems at compile time.
Add this to the top of the file, right beneath the line `require 'motion/project'`
:code
# lang: ruby
require 'bundler'
Bundler.require
.bullet
.description
Next, install your dependencies:
:code
$ bundle install
.bullet
.description
Now you can just compile your app as normal.
:code
$ bundle exec rake