Skip to content
This repository
Newer
Older
100644 816 lines (575 sloc) 27.84 kb
b213de2f »
2011-08-06 update changelog for 1.1.pre.6
1 ## 1.1.pre.6 (Aug 6, 2011)
2
3 Bugfixes:
4
5 - Fix cross repository dependencies (#1138)
6 - Fix git dependency fetching from API endpoint (#1254)
7 - Fixes for bundle outdated (@joelmoss, #1238)
8
9 Features:
10
11 - Implement `to_ary` to avoid calls to method_missing (@tenderlove, #1274)
12 - bundle clean removes old .gem files (@cldwalker, #1293)
13 - Correcly identify missing child dependency in error message
14 - Run pre-install, post-build, and post-install gem hooks for git gems (@warhammerkid, #1120)
15
c2dbfc9e »
2011-06-11 Version 1.1.pre.5
16 ## 1.1.pre.5 (June 11, 2011)
17
18 Bugfixes:
19
20 - Fix LazySpecification on Ruby 1.9 (@dpiddy, #1232)
21 - Fix HTTP proxy support (@leobessa, #878)
22
23 Features:
24
25 - Speed up `install --deployment` by using the API endpoint
26 - Support Basic HTTP Auth for the API endpoint (@dpiddy, #1229)
27 - Add `install --full-index` to disable the API endpoint, just in case
28 - Significantly speed up install by removing unneeded gemspec fetches
29 - `outdated` command shows outdated gems (@joelmoss, #1130)
30 - Print gem post install messages (@csquared, #1155)
31 - Reduce memory use by removing Specification.new inside method_missing (@tenderlove, #1222)
32 - Allow `check --path`
33
54267278 »
2011-06-11 fix date format in CHANGELOG
34 ## 1.1.pre.4 (May 5, 2011)
dd302a9d »
2011-05-05 Version 1.1.pre.4
35
36 Bugfixes:
37
38 - Fix bug that could prevent installing new gems
39
54267278 »
2011-06-11 fix date format in CHANGELOG
40 ## 1.1.pre.3 (May 4, 2011)
71c29aff »
2011-04-30 Version 1.1.pre.3
41
42 Features:
43
44 - Add `bundle outdated` to show outdated gems (@joelmoss)
45 - Remove BUNDLE_* from `Bundler.with_clean_env` (@wuputah)
46 - Add Bundler.clean_system, and clean_exec (@wuputah)
47 - Use git config for gem author name and email (@krekoten)
48
49 Bugfixes:
50
51 - Fix error calling Bundler.rubygems.gem_path
52 - Fix error when Gem.path returns Gem::FS instead of String
53
17235eb5 »
2011-04-28 Changelog for 1.1.pre.2
54 ## 1.1.pre.2 (April 28, 2011)
55
56 Features:
57
58 - Add :github option to Gemfile DSL for easy git repos
59 - Merge all fixes from 1.0.12 and 1.0.13
60
31522380 »
2011-02-02 Version 1.1.pre.1
61 ## 1.1.pre.1 (February 2, 2011)
62
63 Bugfixes:
64
65 - Compatibility with changes made by Rubygems 1.5
66
facde9d8 »
2011-01-21 Truly, we live in the future
67 ## 1.1.pre (January 21, 2011)
a924ea3a »
2011-01-21 Changelog for 1.1.pre
68
69 Features:
70
71 - Add bundle clean. Removes unused gems from --path directory
72 - Initial Gemcutter Endpoint API work, BAI Fetching source index
73 - Added bundle install --standalone
74 - Ignore Gemfile.lock when buliding new gems
75 - Make it possible to override a .gemspec dependency's source in the
76 Gemfile
77
78 Removed:
79
80 - Removed bundle lock
81 - Removed bundle install <path>
82 - Removed bundle install --production
83 - Removed bundle install --disable-shared-gems
8e6bc165 »
2011-08-06 Merge branch '1-0-stable'
84
ba23f523 »
2011-08-06 update changelog for bundler 1.0.16
85 ## 1.0.16 (Aug 6, 2011)
86
87 Features:
88
89 - documentation for gem ..., :require => false (@kmayer, #1292)
90 - Work around File.basename not working on Windows network share paths like "\\Somewhere\gitrepo" (@mtscout6, #1253)
91
92 - gems provide "executables", they are rarely also binaries (@fxn, #1242)
93 - Make templates consistent (@bowsersenior, #1306)
94 - Performance fix for MRI 1.9 (@efficientcloud, #1288)
95 - check for rubygems.org when publishing gem (#980)
96 - enable shortcuts for subcommands (@amatsuda)
97
98 Bugfixes:
99
100 - Fix for bundle package with rubygems 1.3.x (@dburt, #1202)
101 - Fix bundle install --without on kiji (@tmm1, #1287)
102 - Get rid of warning in ruby 1.9.3 (@smartinez87, #1231)
103
1c39e232 »
2011-06-09 Version 1.0.15
104 ## 1.0.15 (June 9, 2011)
105
106 Features:
107
108 - Improved Rubygems integration, removed many deprecation notices
109
110 Bugfixes:
111
112 - Escape URL arguments to git correctly on Windows (1.0.14 regression)
113
365ce956 »
2011-05-27 Changelog for v1.0.14
114 ## 1.0.14 (May 27, 2011)
115
116 Features:
117
118 - Rubinius platform :rbx (@rkbodenner)
119 - Include gem rake tasks with "require 'bundler/gem_tasks" (@indirect)
120 - Include user name and email from git config in new gemspec (@ognevsky)
121
122 Bugfixes:
123
124 - Set file permissions after checking out git repos (@tissak)
125 - Remove deprecated call to Gem::SourceIndex#all_gems (@mpj)
126 - Require the version file in new gemspecs (@rubiii)
127 - Allow relative paths from the Gemfile in gems with no gemspec (@mbirk)
128 - Install gems that contain 'bundler', e.g. guard-bundler (@hone)
129 - Display installed path correctly on Windows (@tadman)
130 - Escape quotes in git URIs (@mheffner)
131 - Improve Rake 0.9 support (@quix)
132 - Handle certain directories already existing (@raggi)
133 - Escape filenames containing regex characters (@indirect)
a924ea3a »
2011-01-21 Changelog for 1.1.pre
134
9fedde21 »
2011-05-04 update changelog
135 ## 1.0.13 (May 4, 2011)
364b278a »
2011-04-28 Version 1.0.13
136
137 Features:
138
d276109e »
2011-04-30 Update changelog for 1.0.13
139 - Compatibility with Rubygems master (soon to be v1.8) (@evanphx)
364b278a »
2011-04-28 Version 1.0.13
140 - Informative error when --path points to a broken symlink
d276109e »
2011-04-30 Update changelog for 1.0.13
141 - Support Rake 0.9 and greater (@e2)
142 - Output full errors for non-TTYs e.g. pow (@josh)
143
144 Bugfixes:
145
146 - Allow spaces in gem path names for gem tasks (@rslifka)
9fedde21 »
2011-05-04 update changelog
147 - Have cap run bundle install from release_path (@martinjagusch)
148 - Quote git refspec so zsh doesn't expand it (@goneflyin)
364b278a »
2011-04-28 Version 1.0.13
149
60ca0d41 »
2011-04-08 Version 1.0.12
150 ## 1.0.12 (April 8, 2011)
151
152 Features:
153
154 - Add --no-deployment option to `install` for disabling it on dev machines
155 - Better error message when git fails and cache is present (@parndt)
156 - Honor :bundle_cmd in cap `rake` command (@voidlock, @cgriego)
157
158 Bugfixes:
159
a250f487 »
2011-04-08 wrong evan
160 - Compatibility with Rubygems 1.7 and Rails 2.3 and vendored gems (@evanphx)
60ca0d41 »
2011-04-08 Version 1.0.12
161 - Fix changing gem order in lock (@gucki)
162 - Remove color escape sequences when displaying man pages (@bgreenlee)
163 - Fix creating GEM_HOME on both JRuby 1.5 and 1.6 (@nickseiger)
164 - Fix gems without a gemspec and directories in bin/ (@epall)
165 - Fix --no-prune option for `bundle install` (@cmeiklejohn)
166
ec1d4dd0 »
2011-04-01 Version 1.0.11
167 ## 1.0.11 (April 1, 2011)
168
169 Features:
170
171 - Compatibility with Rubygems 1.6 and 1.7
172 - Better error messages when a git command fails
173
174 Bugfixes:
175
176 - Don't always update gemspec gems (@carllerche)
177 - Remove ivar warnings (@jackdempsey)
178 - Fix occasional git failures in zsh (@jonah-carbonfive)
179 - Consistent lock for gems with double deps like Cap (@akahn)
180
800e408b »
2011-02-01 Version 1.0.10
181 ## 1.0.10 (February 1, 2011)
182
183 Bugfixes:
184
185 - Fix a regression loading YAML gemspecs from :git and :path gems
186 - Requires, namespaces, etc. to work with changes in Rubygems 1.5
187
facde9d8 »
2011-01-21 Truly, we live in the future
188 ## 1.0.9 (January 19, 2011)
3f0a1e88 »
2011-01-19 Changelog for v1.0.9
189
190 Bugfixes:
191
192 - Fix a bug where Bundler.require could remove gems from the load
193 path. In Rails apps with a default application.rb, this removed
a924ea3a »
2011-01-21 Changelog for 1.1.pre
194 all gems in groups other than :default and Rails.env
3f0a1e88 »
2011-01-19 Changelog for v1.0.9
195
facde9d8 »
2011-01-21 Truly, we live in the future
196 ## 1.0.8 (January 18, 2011)
8d68dc48 »
2011-01-18 changelog for v1.0.8
197
198 Features:
199
200 - Allow overriding gemspec() deps with :git deps
201 - Add --local option to `bundle update`
202 - Ignore Gemfile.lock in newly generated gems
203 - Use `less` as help pager instead of `more`
204 - Run `bundle exec rake` instead of `rake` in Capistrano tasks
205
206 Bugfixes:
207
208 - Fix --no-cache option for `bundle install`
209 - Allow Vlad deploys to work without Capistrano gem installed
210 - Fix group arguments to `bundle console`
211 - Allow groups to be loaded even if other groups were loaded
212 - Evaluate gemspec() gemspecs in their directory not the cwd
213 - Count on Rake to chdir to the right place in GemHelper
214 - Change Pathnames to Strings for MacRuby
215 - Check git process exit status correctly
216 - Fix some warnings in 1.9.3-trunk (thanks tenderlove)
217
8dc821fc »
2010-11-17 Version 1.0.7 with changelog
218 ## 1.0.7 (November 17, 2010)
219
220 Bugfixes:
221
222 - Remove Bundler version from the lockfile because it broke
223 backwards compatibility with 1.0.0-1.0.5. Sorry. :(
224
a0722f39 »
2010-11-16 Fix 1.0.6 release date
225 ## 1.0.6 (November 16, 2010)
cd6e02f4 »
2010-11-16 Version 1.0.6 with changelog
226
227 Bugfixes:
228
229 - Fix regression in `update` that caused long/wrong results
230 - Allow git gems on other platforms while installing (#579)
231
232 Features:
233
234 - Speed up `install` command using various optimizations
235 - Significantly increase performance of resolver
236 - Use upcoming Rubygems performance improvements (@tmm1)
237 - Warn if the lockfile was generated by a newer version
238 - Set generated gems' homepage to "", so Rubygems will warn
239
6a94687b »
2010-11-13 Version 1.0.5 with changelog
240 ## 1.0.5 (November 13, 2010)
241
242 Bugfixes:
243
244 - Fix regression disabling all operations that employ sudo
245
4d4fa00f »
2010-11-13 Version 1.0.4 with changelog
246 ## 1.0.4 (November 12, 2010)
247
248 Bugfixes:
249
250 - Expand relative :paths from Bundler.root (eg ./foogem)
251 - Allow git gems in --without groups while --frozen
252 - Allow gem :ref to be a symbol as well as a string
253 - Fix exception when Gemfile needs a newer Bundler version
254 - Explanation when the current Bundler version conflicts
255 - Explicit error message if Gemfile needs newer Bundler
256 - Ignore an empty string BUNDLE_GEMFILE
257 - Skeleton gemspec now works with older versions of git
258 - Fix shell quoting and ref fetching in GemHelper
259 - Disable colored output in --deployment
260 - Preserve line endings in lock file
261
262 Features:
263
264 - Add support for 'mingw32' platform (aka RubyInstaller)
265 - Large speed increase when Gemfile.lock is already present
266 - Huge speed increase when many (100+) system gems are present
267 - Significant expansion of ISSUES, man pages, and docs site
268 - Remove Open3 from GemHelper (now it works on Windows™®©)
269 - Allow setting roles in built-in cap and vlad tasks
270
e0fc27d0 »
2010-10-15 Version 1.0.3 with changelog
271 ## 1.0.3 (October 15, 2010)
48681835 »
2010-10-02 Changelog for v1.0.2
272
273 Bugfixes:
274
e0fc27d0 »
2010-10-15 Version 1.0.3 with changelog
275 - Use bitwise or in #hash to reduce the chance of overflow
276 - `bundle update` now works with :git + :tag updates
277 - Record relative :path options in the Gemfile.lock
278 - :groups option on gem method in Gemfile now works
279 - Add #platform method and :platform option to Gemfile DSL
280 - --without now accepts a quoted, space-separated list
281 - Installing after --deployment with no lock is now possible
282 - Binstubs can now be symlinked
283 - Print warning if cache for --local install is missing gems
284 - Improve output when installing to a path
285 - The tests all pass! Yay!
286
287 ## 1.0.2 (October 2, 2010)
288
289 Bugfix:
290
48681835 »
2010-10-02 Changelog for v1.0.2
291 - Actually include the man pages in the gem, so help works
292
1fa4f553 »
2010-10-01 Update changelog for 1.0.1
293 ## 1.0.1 (October 1, 2010)
0bf09249 »
2010-08-30 Update CHANGELOG for 1.0.0
294
1fa4f553 »
2010-10-01 Update changelog for 1.0.1
295 Features:
296
297 - Vlad deployment recipe, `require 'bundler/vlad'`
298 - Prettier bundle graphs
299 - Improved gem skeleton for `bundle gem`
300 - Prompt on file clashes when generating a gem
301 - Option to generate binary with gem skeleton
302 - Allow subclassing of GemHelper for custom tasks
303 - Chdir to gem directory during `bundle open`
304
305 Bugfixes:
306
307 - Allow gemspec requirements with a list of versions
308 - Accept lockfiles with windows line endings
309 - Respect BUNDLE_WITHOUT env var
310 - Allow `gem "foo", :platform => :jruby`
311 - Specify loaded_from path in fake gemspec
312 - Flesh out gem_helper tasks, raise errors correctly
313 - Respect RBConfig::CONFIG['ruby_install_name'] in binstubs
314
315 ## 1.0.0 (August 29, 2010)
316
317 Features:
0bf09249 »
2010-08-30 Update CHANGELOG for 1.0.0
318
319 - You can now define `:bundle_cmd` in the capistrano task
320
321 Bugfixes:
322
323 - Various bugfixes to the built-in rake helpers
324 - Fix a bug where shortrefs weren't unique enough and were
325 therfore colliding
326 - Fix a small bug involving checking whether a local git
327 clone is up to date
328 - Correctly handle explicit '=' dependencies with gems
329 pinned to a git source
330 - Fix an issue with Windows-generated lockfiles by reading
331 and writing the lockfile in binary mode
332 - Fix an issue with shelling out to git in Windows by
333 using double quotes around paths
334 - Detect new Rubygems sources in the Gemfile and update
335 the lockfile
336
1fa4f553 »
2010-10-01 Update changelog for 1.0.1
337 ## 1.0.0.rc.6 (August 23, 2010)
4779cb88 »
2010-08-23 Update changelog
338
339 Features:
340
341 - Much better documentation for most of the commands and Gemfile
342 format
343
e09a8cc6 »
2010-08-23 typo in changelog
344 Bugfixes:
4779cb88 »
2010-08-23 Update changelog
345
346 - Don't attempt to create directories if they already exist
347 - Fix the capistrano task so that it actually runs
348 - Update the Gemfile template to reference rubygems.org instead
349 of :gemcutter
350 - bundle exec should exit with a non zero exit code when the gem
351 binary does not exist or the file is not executable.
352 - Expand paths in Gemfile relative to the Gemfile and not the current
353 working directory.
354
1fa4f553 »
2010-10-01 Update changelog for 1.0.1
355 ## 1.0.0.rc.5 (August 10, 2010)
3c21459b »
2010-08-10 Update the changelog
356
357 Features:
358
359 - Make the Capistrano task more concise.
360
361 Bugfixes:
362
363 - Fix a regression with determining whether or not to use sudo
364 - Allow using the --gemfile flag with the --deployment flag
365
1fa4f553 »
2010-10-01 Update changelog for 1.0.1
366 ## 1.0.0.rc.4 (August 9, 2010)
ef030f26 »
2010-08-04 Minor tweaks and cleanups to gem
367
368 Features:
369
370 - `bundle gem NAME` command to generate a new gem with Gemfile
8b199ca2 »
2010-08-09 Update changelog for RC4
371 - Bundle config file location can be specified by BUNDLE_APP_CONFIG
372 - Add --frozen to disable updating the Gemfile.lock at runtime
323c07c4 »
2010-08-09 Clarify a new feature
373 (default with --deployment)
8b199ca2 »
2010-08-09 Update changelog for RC4
374 - Basic Capistrano task now added as 'bundler/capistrano'
375
376 Bugfixes:
377
378 - Multiple bundler process no longer share a tmp directory
379 - `bundle update GEM` always updates dependencies of GEM as well
380 - Deleting the cache directory no longer causes errors
381 - Moving the bundle after installation no longer causes git errors
382 - Bundle path is now correctly remembered on a read-only filesystem
383 - Gem binaries are installed to Gem.bindir, not #{Gem.dir}/bin
384 - Fetch gems from vendor/cache, even without --local
385 - Sort lockfile by platform as well as spec
ef030f26 »
2010-08-04 Minor tweaks and cleanups to gem
386
7d8e24e8 »
2010-08-03 Fix changelog typo
387 ## 1.0.0.rc.3 (August 3, 2010)
530b5116 »
2010-08-03 Version 1.0.0.rc.3
388
389 Features:
390
391 - Deprecate --production flag for --deployment, since the former
392 was causing confusion with the :production group
393 - Add --gemfile option to `bundle check`
394 - Reduce memory usage of `bundle install` by 2-4x
395 - Improve message from `bundle check` under various conditions
396 - Better error when a changed Gemfile conflicts with Gemfile.lock
397
398 Bugfixes:
399
400 - Create bin/ directory if it is missing, then install binstubs
401 - Error nicely on the edge case of a pinned gem with no spec
402 - Do not require gems for other platforms
403 - Update git sources along with the gems they contain
404
1c73e636 »
2010-07-29 Update CHANGELOG for rc.2
405 ## 1.0.0.rc.2 (July 29, 2010)
406
407 - `bundle install path` was causing confusion, so we now print
408 a clarifying warning. The preferred way to install to a path
409 (which will not print the warning) is
410 `bundle install --path path/to/install`.
411 - `bundle install --system` installs to the default system
412 location ($BUNDLE_PATH or $GEM_HOME) even if you previously
413 used `bundle install --path`
414 - completely remove `--disable-shared-gems`. If you install to
415 system, you will not be isolated, while if you install to
416 another path, you will be isolated from gems installed to
417 the system. This was mostly an internal option whose naming
418 and semantics were extremely confusing.
419 - Add a `--production` option to `bundle install`:
420 - by default, installs to `vendor/bundle`. This can be
421 overridden with the `--path` option
422 - uses `--local` if `vendor/cache` is found. This will
423 guarantee that Bundler does not attempt to connect to
424 Rubygems and will use the gems cached in `vendor/cache`
425 instead
426 - Raises an exception if a Gemfile.lock is not found
427 - Raises an exception if you modify your Gemfile in development
428 but do not check in an updated Gemfile.lock
429 - Fixes a bug where switching a source from Rubygems to git
430 would always say "the git source is not checked out" when
431 running `bundle install`
432
433 NOTE: We received several reports of "the git source has not
434 been checked out. Please run bundle install". As far as we
435 can tell, these problems have two possible causes:
436
437 1. `bundle install ~/.bundle` in one user, but actually running
438 the application as another user. Never install gems to a
439 directory scoped to a user (`~` or `$HOME`) in deployment.
440 2. A bug that happened when changing a gem to a git source.
441
442 To mitigate several common causes of `(1)`, please use the
443 new `--production` flag. This flag is simply a roll-up of
444 the best practices we have been encouraging people to use
445 for deployment.
446
447 If you want to share gems across deployments, and you use
448 Capistrano, symlink release_path/current/vendor/bundle to
15d68bff »
2010-09-08 Fix typo in changelog
449 release_path/shared/bundle. This will keep deployments
1c73e636 »
2010-07-29 Update CHANGELOG for rc.2
450 snappy while maintaining the benefits of clean, deploy-time
451 isolation.
452
5bdb507b »
2010-07-26 Update CHANGELOG
453 ## 1.0.0.rc.1 (July 26, 2010)
454
455 - Fixed a bug with `bundle install` on multiple machines and git
456
848ca64f »
2010-07-25 Update changelog for 1.0.0.beta.10
457 ## 1.0.0.beta.10 (July 25, 2010)
458
459 - Last release before 1.0.0.rc.1
460 - Added :mri as a valid platform (platforms :mri { gem "ruby-debug" })
461 - Fix `bundle install` immediately after modifying the :submodule option
462 - Don't write to Gemfile.lock if nothing has changed, fixing situations
463 where bundle install was run with a different user than the app
464 itself
465 - Fix a bug where other platforms were being wiped on `bundle update`
466 - Don't ask for root password on `bundle install` if not needed
467 - Avoid setting `$GEM_HOME` where not needed
468 - First solid pass of `bundle config`
469 - Add build options
470 - `bundle config build.mysql --with-mysql-config=/path/to/config`
471
9bcd6083 »
2010-07-21 Update Changelog for beta9 and backfill the past few days of fun
472 ## 1.0.0.beta.9 (July 21, 2010)
473
474 - Fix install failure when switching from a path to git source
475 - Fix `bundle exec bundle *` in a bundle with --disable-shared-gems
476 - Fix `bundle *` from inside a bundle with --disable-shared-gem
477 - Shim Gem.refresh. This is used by Unicorn
478 - Fix install failure when a path's dependencies changed
479
480 ## 1.0.0.beta.8 (July 20, 2010)
481
482 - Fix a Beta 7 bug involving Ruby 1.9
483
484 ## 1.0.0.beta.7 (July 20, 2010, yanked)
485
486 - Running `bundle install` twice in a row with a git source always crashed
487
488 ## 1.0.0.beta.6 (July 20, 2010, yanked)
489
490 - Create executables with bundle install --binstubs
491 - You can customize the location (default is app/bin) with --binstubs other/location
492 - Fix a bug where the Gemfile.lock would be deleted even if the update was exited
493 - Fix a bug where cached gems for other platforms were sometimes deleted
494 - Clean up output when nothing was deleted from cache (it previously said
495 "Removing outdated gems ...")
496 - Improve performance of bundle install if the git gem was already checked out,
497 and the revision being used already exists locally
498 - Fix bundle show bundler in some cases
499 - Fix bugs with bundle update
500 - Don't ever run git commands at runtime (fixes a number of common passenger issues)
501 - Fixes an obscure bug where switching the source of a gem could fail to correctly
502 change the source of its dependencies
503 - Support multiple version dependencies in the Gemfile
504 (gem "rails", ">= 3.0.0.beta1", "<= 3.0.0")
505 - Raise an exception for ambiguous uses of multiple declarations of the same gem
506 (for instance, with different versions or sources).
507 - Fix cases where the same dependency appeared several times in the Gemfile.lock
508 - Fix a bug where require errors were being swallowed during Bundler.require
509
510 ## 1.0.0.beta.1
96c30c06 »
2010-04-23 Update the changelog
511
512 - No `bundle lock` command. Locking happens automatically on install or update
513 - No .bundle/environment.rb. Require 'bundler/setup' instead.
514 - $BUNDLE_HOME defaults to $GEM_HOME instead of ~/.bundle
58dab277 »
2010-06-07 Remove lockfiles generated by 0.9
515 - Remove lockfiles generated by 0.9
96c30c06 »
2010-04-23 Update the changelog
516
a27dbd4a »
2010-06-07 Error on lockfiles generated by 0.10
517 ## 0.9.26
518
519 Features:
520
521 - error nicely on incompatible 0.10 lockfiles
522
62814229 »
2010-05-03 Version 0.9.25
523 ## 0.9.25 (May 3, 2010)
524
525 Bugfixes:
526
a27dbd4a »
2010-06-07 Error on lockfiles generated by 0.10
527 - explicitly coerce Pathname objects to Strings for Ruby 1.9
528 - fix some newline weirdness in output from install command
62814229 »
2010-05-03 Version 0.9.25
529
6ea2d9b5 »
2010-04-23 Merge changelog up to 0.9.24
530 ## 0.9.24 (April 22, 2010)
531
532 Features:
533
534 - fetch submodules for git sources
535 - limit the bundled version of bundler to the same as the one installing
536 - force relative paths in git gemspecs to avoid raising Gem::NameTooLong
537 - serialize GemCache sources correctly, so locking works
538 - raise Bundler::GemNotFound instead of calling exit! inside library code
539 - Rubygems 1.3.5 compatibility for the adventurous, not supported by me :)
540
541 Bugfixes:
542
543 - don't try to regenerate environment.rb if it is read-only
544 - prune outdated gems with the platform "ruby"
545 - prune cache without errors when there are directories or non-gem files
546 - don't re-write environment.rb if running after it has been loaded
547 - do not monkeypatch Specification#load_paths twice when inside a bundle
548
549 ## 0.9.23 (April 20, 2010)
550
551 Bugfixes:
552
553 - cache command no longer prunes gems created by an older rubygems version
554 - cache command no longer prunes gems that are for other platforms
555
556 ## 0.9.22 (April 20, 2010)
557
558 Features:
559
560 - cache command now prunes stale .gem files from vendor/cache
561 - init --gemspec command now generates development dependencies
562 - handle Polyglot's changes to Kernel#require with Bundler::ENV_LOADED (#287)
563 - remove .gem files generated after installing a gem from a :path (#286)
564 - improve install/lock messaging (#284)
565
566 Bugfixes:
567
568 - ignore cached gems that are for another platform (#288)
569 - install Windows gems that have no architecture set, like rcov (#277)
570 - exec command while locked now includes the bundler lib in $LOAD_PATH (#293)
571 - fix the `rake install` task
572 - add GemspecError so it can be raised without (further) error (#292)
573 - create a parent directory before cloning for git 1.5 compatibility (#285)
574
41c9dc68 »
2010-04-16 Version 0.9.21
575 ## 0.9.21 (April 16, 2010)
576
577 Bugfixes:
578
579 - don't raise 'omg wtf' when lockfile is outdated
580
6c41a0be »
2010-04-15 Version 0.9.20
581 ## 0.9.20 (April 15, 2010)
582
583 Features:
584
585 - load YAML format gemspecs
586 - no backtraces when calling Bundler.setup if gems are missing
587 - no backtraces when trying to exec a file without the executable bit
588
589 Bugfixes:
590
591 - fix infinite recursion in Bundler.setup after loading a bundled Bundler gem
592 - request install instead of lock when env.rb is out of sync with Gemfile.lock
593
4754b367 »
2010-04-12 Version 0.9.19
594 ## 0.9.19 (April 12, 2010)
595
596 Features:
597
598 - suggest `bundle install --relock` when the Gemfile has changed (#272)
599 - source support for Rubygems servers without prerelease gem indexes (#262)
600
601 Bugfixes:
602
603 - don't set up all groups every time Bundler.setup is called while locked (#263)
604 - fix #full_gem_path for git gems while locked (#268)
605 - eval gemspecs at the top level, not inside the Bundler class (#269)
606
607
287d3f11 »
2010-04-08 Version 0.9.18
608 ## 0.9.18 (April 8, 2010)
609
610 Features:
611
612 - console command that runs irb with bundle (and optional group) already loaded
613
614 Bugfixes:
615
616 - Bundler.setup now fully disables system gems, even when unlocked (#266, #246)
617 - fixes Yard, which found plugins in Gem.source_index that it could not load
618 - makes behaviour of `Bundler.require` consistent between locked and unlocked loads
619
75473e78 »
2010-04-07 Version bump to 0.9.17
620 ## 0.9.17 (April 7, 2010)
621
622 Features:
623
624 - Bundler.require now calls Bundler.setup automatically
625 - Gem::Specification#add_bundler_dependencies added for gemspecs
626
627 Bugfixes:
628
629 - Gem paths are not longer duplicated while loading bundler
630 - exec no longer duplicates RUBYOPT if it is already set correctly
631
6be2abff »
2010-04-03 Release version to 0.9.16
632 ## 0.9.16 (April 3, 2010)
633
634 Features:
635
636 - exit gracefully on INT signal
637 - resolver output now indicates whether remote sources were checked
638 - print error instead of backtrace when exec cannot find a binary (#241)
639
640 Bugfixes:
641
642 - show, check, and open commands work again while locked (oops)
643 - show command for git gems
644 - outputs branch names other than master
645 - gets the correct sha from the checkout
646 - doesn't print sha twice if :ref is set
647 - report errors from bundler/setup.rb without backtraces (#243)
648 - fix Gem::Spec#git_version to not error on unloaded specs
649 - improve deprecation, Gemfile, and command error messages (#242)
650
8e8bdcc5 »
2010-04-02 Changelog and release for 0.9.15
651 ## 0.9.15 (April 1, 2010)
652
653 Features:
654
6be2abff »
2010-04-03 Release version to 0.9.16
655 - use the env_file if possible instead of doing a runtime resolve
656 - huge speedup when calling Bundler.setup while locked
657 - ensures bundle exec is fast while locked
658 - regenerates env_file if it was generated by an older version
659 - update cached/packed gems when you update gems via bundle install
8e8bdcc5 »
2010-04-02 Changelog and release for 0.9.15
660
661 Bugfixes:
662
6be2abff »
2010-04-03 Release version to 0.9.16
663 - prep for Rubygems 1.3.7 changes
664 - install command now pulls git branches correctly (#211)
665 - raise errors on invalid options in the Gemfile
8e8bdcc5 »
2010-04-02 Changelog and release for 0.9.15
666
569d0a22 »
2010-03-30 Changelog for 0.9.14
667 ## 0.9.14 (March 30, 2010)
668
669 Features:
670
671 - install command output vastly improved
672 - installation message now accurate, with 'using' and 'installing'
673 - bundler gems no longer listed as 'system gems'
674 - show command output now includes sha and branch name for git gems
675 - init command now takes --gemspec option for bootstrapping gem Gemfiles
676 - Bundler.with_clean_env for shelling out to ruby scripts
677 - show command now aliased as 'list'
678 - VISUAL env var respected for GUI editors
679
680 Bugfixes:
681
682 - exec command now finds binaries from gems with no gemspec
683 - note source of Gemfile resolver errors
684 - don't blow up if git urls are changed
685
20f25086 »
2010-03-25 Update changelog and link from readme
686 ## 0.9.13 (March 23, 2010)
687
688 Bugfixes:
689
690 - exec command now finds binaries from gems installed via :path
691 - gem dependencies are pulled in even if their type is nil
692 - paths with spaces have double-quotes to work on Windows
693 - set GEM_PATH in environment.rb so generators work with Rails 2
694
695 ## 0.9.12 (March 17, 2010)
696
697 - refactoring, internal cleanup, more solid specs
698
699 Features:
700
701 - check command takes a --without option
702 - check command exits 1 if the check fails
54a42ce9 »
2010-03-10 Update the changelog
703
704 Bugfixes:
705
706 - perform a topological sort on resolved gems (#191)
20f25086 »
2010-03-25 Update changelog and link from readme
707 - gems from git work even when paths or repos have spaces (#196)
708 - Specification#loaded_from returns a String, like Gem::Specification (#197)
e901aa4f »
2010-03-29 Whitespace
709 - specs eval from inside the gem directory, even when locked
20f25086 »
2010-03-25 Update changelog and link from readme
710 - virtual gemspecs are now saved in environment.rb for use when loading
711 - unify the Installer's local index and the runtime index (#204)
54a42ce9 »
2010-03-10 Update the changelog
712
024931c1 »
2010-03-10 Flesh out changelog
713 ## 0.9.11 (March 9, 2010)
3a383f81 »
2010-03-09 Add changelog, standardize text files
714
024931c1 »
2010-03-10 Flesh out changelog
715 - added roadmap with future development plans
716
717 Features:
718
719 - install command can take the path to the gemfile with --gemfile (#125)
3a383f81 »
2010-03-09 Add changelog, standardize text files
720 - unknown command line options are now rejected (#163)
024931c1 »
2010-03-10 Flesh out changelog
721 - exec command hugely sped up while locked (#177)
722 - show command prints the install path if you pass it a gem name (#148)
723 - open command edits an installed gem with $EDITOR (#148)
724 - Gemfile allows assigning an array of groups to a gem (#114)
725 - Gemfile allows :tag option on :git sources
726 - improve backtraces when a gemspec is invalid
727 - improve performance by installing gems from the cache if present
728
729 Bugfixes:
730
731 - normalize parameters to Bundler.require (#153)
732 - check now checks installed gems rather than cached gems (#162)
733 - don't update the gem index when installing after locking (#169)
3a383f81 »
2010-03-09 Add changelog, standardize text files
734 - bundle parenthesises arguments for 1.8.6 (#179)
024931c1 »
2010-03-10 Flesh out changelog
735 - gems can now be assigned to multiple groups without problems (#135)
736 - fix the warning when building extensions for a gem from git with Rubygems 1.3.6
737 - fix a Dependency.to_yaml error due to accidentally including sources and groups
738 - don't reinstall packed gems
739 - fix gems with git sources that are private repositories
740
741 ## 0.9.10 (March 1, 2010)
742
743 - depends on Rubygems 1.3.6
744
745 Bugfixes:
746
747 - support locking after install --without
748 - don't reinstall gems from the cache if they're already in the bundle
749 - fixes for Ruby 1.8.7 and 1.9
750
751 ## 0.9.9 (February 25, 2010)
752
753 Bugfixes:
754
755 - don't die if GEM_HOME is an empty string
756 - fixes for Ruby 1.8.6 and 1.9
757
758 ## 0.9.8 (February 23, 2010)
759
760 Features:
761
762 - pack command which both caches and locks
763 - descriptive error if a cached gem is missing
764 - remember the --without option after installing
765 - expand paths given in the Gemfile via the :path option
766 - add block syntax to the git and group options in the Gemfile
767 - support gems with extensions that don't admit they depend on rake
768 - generate gems using gem build gemspec so git gems can have native extensions
769 - print a useful warning if building a gem fails
770 - allow manual configuration via BUNDLE_PATH
771
772 Bugfixes:
773
774 - eval gemspecs in the gem directory so relative paths work
775 - make default spec for git sources valid
776 - don't reinstall gems that are already packed
777
778 ## 0.9.7 (February 17, 2010)
779
780 Bugfixes:
781
782 - don't say that a gem from an excluded group is "installing"
783 - improve crippling rubygems in locked scenarios
784
785 ## 0.9.6 (February 16, 2010)
786
787 Features:
788
789 - allow String group names
790 - a number of improvements in the documentation and error messages
791
792 Bugfixes:
793
794 - set SourceIndex#spec_dirs to solve a problem involving Rails 2.3 in unlocked mode
795 - ensure Rubygems is fully loaded in Ruby 1.9 before patching it
796 - fix `bundle install` for a locked app without a .bundle directory
797 - require gems in the order that the resolver determines
798 - make the tests platform agnostic so we can confirm that they're green on JRuby
799 - fixes for Ruby 1.9
800
801 ## 0.9.5 (Feburary 12, 2010)
802
803 Features:
804
805 - added support for :path => "relative/path"
806 - added support for older versions of git
807 - added `bundle install --disable-shared-gems`
808 - Bundler.require fails silently if a library does not have a file on the load path with its name
809 - Basic support for multiple rubies by namespacing the default bundle path using the version and engine
810
811 Bugfixes:
812
813 - if the bundle is locked and .bundle/environment.rb is not present when Bundler.setup is called, generate it
814 - same if it's not present with `bundle check`
815 - same if it's not present with `bundle install`
Something went wrong with that request. Please try again.