Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Browse files

Merge branch '1-2-stable'

  • Loading branch information...
commit 3110341860fa6e3fecdb89be6ab840a78e0e04d9 2 parents 0bd5b93 + 41e7cc2
@hone hone authored
View
10 CHANGELOG.md
@@ -1,3 +1,13 @@
+## 1.2.0 (Aug 30, 2012)
+
+Bugfixes:
+
+ - raise original error message from LoadError's
+
+Documentation:
+
+ - `platform` man pages
+
## 1.2.0.rc.2 (Aug 8, 2012)
Bugfixes:
View
1  lib/bundler/cli.rb
@@ -35,6 +35,7 @@ def help(cli = nil)
bundle-install
bundle-package
bundle-update
+ bundle-platform
gemfile.5)
if manpages.include?(command)
View
2  lib/bundler/version.rb
@@ -2,5 +2,5 @@ module Bundler
# We're doing this because we might write tests that deal
# with other versions of bundler and we are unsure how to
# handle this better.
- VERSION = "1.2.0.rc.2" unless defined?(::Bundler::VERSION)
+ VERSION = "1.2.0" unless defined?(::Bundler::VERSION)
end
View
42 man/bundle-platform.ronn
@@ -0,0 +1,42 @@
+bundle-platform(1) -- Displays platform compatibility information
+=================================================================
+
+## SYNOPSIS
+
+`bundle platform` [--ruby]
+
+## DESCRIPTION
+
+`platform` will display information from your Gemfile, Gemfile.lock, and Ruby
+VM about your platform.
+
+For instance, using this Gemfile(5):
+
+ source "http://rubygems.org"
+
+ ruby "1.9.3"
+
+ gem "rack"
+
+If you run `bundle platform` on Ruby 1.9.3, it will display the following output:
+
+ Your platform is: x86_64-linux
+
+ Your app has gems that work on these platforms:
+ * ruby
+
+ Your Gemfile specifies a Ruby version requirement:
+ * ruby 1.9.3
+
+ Your current platform satisfies the Ruby version requirement.
+
+`platform` will list all the platforms in your `Gemfile.lock` as well as the
+`ruby` directive if applicable from your Gemfile(5). It will also let you know
+if the `ruby` directive requirement has been met. If `ruby` directive doesn't
+match the running Ruby VM, it will tell you what part does not.
+
+## OPTIONS
+
+* `--ruby`:
+ It will just display the ruby directive information, so you don't have to
+ parse it from the Gemfile(5).
View
3  man/bundle.ronn
@@ -73,6 +73,9 @@ We divide `bundle` subcommands into primary commands and utilities.
* `bundle gem(1)`:
Create a simple gem, suitable for development with bundler
+* `bundle platform(1)`:
+ Displays platform compatibility information
+
## OBSOLETE
These commands are obsolete and should no longer be used
View
1  man/index.txt
@@ -4,3 +4,4 @@ bundle-update bundle-update.1
bundle-package bundle-package.1
bundle-exec bundle-exec.1
bundle-config bundle-config.1
+bundle-platform bundle-platform.1
Please sign in to comment.
Something went wrong with that request. Please try again.