Permalink
Browse files

that spec is actually 1.8-only. oops.

  • Loading branch information...
1 parent b6bf2af commit 5a4803c46bb4e896630d7eefef9a58e9479c6f7e @indirect indirect committed Oct 21, 2011
Showing with 4 additions and 2 deletions.
  1. +1 −1 spec/realworld/edgecases_spec.rb
  2. +3 −1 spec/spec_helper.rb
@@ -2,7 +2,7 @@
describe "real world edgecases", :realworld => true do
# there is no rbx-relative-require gem that will install on 1.9
- it "ignores extra gems with bad platforms", :ruby => "1.9" do
+ it "ignores extra gems with bad platforms", :ruby => "1.8" do
install_gemfile <<-G
source :rubygems
gem "linecache", "0.46"
View
@@ -52,7 +52,9 @@
config.filter_run_excluding :realworld => true
end
- if RUBY_VERSION < "1.9"
+ if RUBY_VERSION >= "1.9"
+ config.filter_run_excluding :ruby => "1.8"
+ else
config.filter_run_excluding :ruby => "1.9"
end

0 comments on commit 5a4803c

Please sign in to comment.