Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
Browse files

Remove outdated pending specs

  • Loading branch information...
commit 7e8553e92427da76bd64b75d4c03bb01753402bc 1 parent 9ef6aa6
Carlhuda authored indirect committed
Showing with 0 additions and 95 deletions.
  1. +0 −95 spec/runtime/load_spec.rb
View
95 spec/runtime/load_spec.rb
@@ -44,101 +44,6 @@
}.should raise_error(Bundler::GemfileNotFound, /omg\.rb/)
end
- describe "when locked" do
- before :each do
- pending
- system_gems "rack-1.0.0", "activesupport-2.3.2", "activerecord-2.3.2", "activerecord-2.3.1"
- end
-
- it "raises an exception if the Gemfile adds a dependency" do
- gemfile <<-G
- source "file://#{gem_repo1}"
- gem "rack"
- G
-
- bundle :lock
-
- gemfile <<-G
- source "file://#{gem_repo1}"
- gem "rack"
- gem "activerecord"
- G
-
- lambda { Bundler.load }.should raise_error(Bundler::GemfileError)
- end
-
- it "raises an exception if the Gemfile removes a dependency" do
- gemfile <<-G
- source "file://#{gem_repo1}"
- gem "rack"
- gem "activerecord"
- G
-
- bundle :lock
-
- gemfile <<-G
- source "file://#{gem_repo1}"
- gem "rack"
- G
-
- lambda { Bundler.load }.should raise_error(Bundler::GemfileError)
- end
-
- it "raises an exception if the Gemfile changes a dependency in an incompatible way" do
- gemfile <<-G
- source "file://#{gem_repo1}"
- gem "rack"
- gem "activerecord"
- G
-
- bundle :lock
-
- gemfile <<-G
- source "file://#{gem_repo1}"
- gem "rack"
- gem "activerecord", "2.3.1"
- G
-
- lambda { Bundler.load }.should raise_error(Bundler::GemfileError)
- end
-
- it "raises an exception if the Gemfile replaces a root with a child dep of the root" do
- gemfile <<-G
- source "file://#{gem_repo1}"
- gem "rack"
- gem "activerecord"
- G
-
- bundle :lock
-
- gemfile <<-G
- source "file://#{gem_repo1}"
- gem "rack"
- gem "activesupport"
- G
-
- lambda { Bundler.load }.should raise_error(Bundler::GemfileError)
- end
-
- it "works if the Gemfile changes in a compatible way" do
- gemfile <<-G
- source "file://#{gem_repo1}"
- gem "rack"
- gem "activerecord", "2.3.2"
- G
-
- bundle :lock
-
- gemfile <<-G
- source "file://#{gem_repo1}"
- gem "rack"
- gem "activerecord", ">= 2.0.0"
- G
-
- lambda { Bundler.load }.should_not raise_error(Bundler::GemfileError)
- end
- end
-
describe "when called twice" do
it "doesn't try to load the runtime twice" do
system_gems "rack-1.0.0", "activesupport-2.3.5"
Please sign in to comment.
Something went wrong with that request. Please try again.