Skip to content
Browse files

definitely remove things deprecated before 1.0

  • Loading branch information...
1 parent bbaaec8 commit 850b161afa3db92983a6ac6ed086f73d5b97b2fb @indirect indirect committed Apr 14, 2011
Showing with 0 additions and 16 deletions.
  1. +0 −16 lib/bundler/rubygems_ext.rb
View
16 lib/bundler/rubygems_ext.rb
@@ -64,22 +64,6 @@ def nondevelopment_dependencies
dependencies - development_dependencies
end
- def add_bundler_dependencies(*groups)
- Bundler.ui.warn "#add_bundler_dependencies is deprecated and will " \
- "be removed in Bundler 1.0. Instead, please use the #gemspec method " \
- "in your Gemfile, which will pull in any dependencies specified in " \
- "your gemspec"
-
- groups = [:default] if groups.empty?
- Bundler.definition.dependencies.each do |dep|
- if dep.groups.include?(:development)
- self.add_development_dependency(dep.name, dep.requirement.to_s)
- elsif (dep.groups & groups).any?
- self.add_dependency(dep.name, dep.requirement.to_s)
- end
- end
- end
-
private
def dependencies_to_gemfile(dependencies, group = nil)

0 comments on commit 850b161

Please sign in to comment.
Something went wrong with that request. Please try again.