Permalink
Browse files

Fix the help spec for the 0.8 error

  • Loading branch information...
1 parent 3a2a18a commit 9c15875cf5edfc15eeb973d1de9cc5e6d2577f4c @indirect indirect committed Sep 17, 2011
Showing with 5 additions and 2 deletions.
  1. +3 −1 bin/bundle
  2. +2 −1 spec/other/help_spec.rb
View
@@ -4,7 +4,9 @@ begin
# Check if an older version of bundler is installed
$:.each do |path|
if path =~ %r'/bundler-0.(\d+)' && $1.to_i < 9
- abort "Please remove 0.8 versions of bundler. This can be done by running `gem cleanup bundler`."
+ err = "Please remove Bundler 0.8 versions."
+ err << "This can be done by running `gem cleanup bundler`."
+ abort(err)
end
end
require 'bundler/cli'
View
@@ -7,7 +7,8 @@
system_gems "bundler-0.8.1"
bundle "help", :expect_err => true
- err.should == "Please remove older versions of bundler. This can be done by running `gem cleanup bundler`."
+ err.should include("Please remove Bundler 0.8 versions.")
+ err.should include("This can be done by running `gem cleanup bundler`.")
end
it "uses groff when available" do

0 comments on commit 9c15875

Please sign in to comment.