Permalink
Browse files

Revert "return the right error code for bundle exec with ruby version"

This is based on the previously-reverted commit, so I'm reverting it as well for now.

This reverts commit 5ba2081.
  • Loading branch information...
1 parent a18e76f commit 9efbcdf5b94c007538e16d0f15c351248e722002 @indirect indirect committed May 27, 2012
Showing with 0 additions and 9 deletions.
  1. +0 −2 lib/bundler/cli.rb
  2. +0 −6 lib/bundler/setup.rb
  3. +0 −1 spec/other/platform_spec.rb
View
@@ -422,8 +422,6 @@ def exec(*)
Bundler.definition.validate_ruby!
Bundler.load.setup_environment
- ENV['BUNDLE_EXECING'] = options["no-color"] ? "no-color" : "color"
-
begin
# Run
Kernel.exec(*ARGV)
@@ -1,5 +1,4 @@
require 'bundler/shared_helpers'
-require 'bundler/friendly_errors'
if Bundler::SharedHelpers.in_bundle?
require 'bundler'
@@ -14,11 +13,6 @@
end
exit e.status_code
end
- elsif ENV['BUNDLE_EXECING']
- require 'bundler/vendored_thor'
- the_shell = (ENV['BUNDLE_EXECING'] == "no-color" ? Thor::Shell::Basic.new : Thor::Base.shell.new)
- Bundler.ui = Bundler::UI::Shell.new(the_shell)
- Bundler.with_friendly_errors {Bundler.setup }
else
Bundler.setup
end
@@ -592,7 +592,6 @@ def should_be_engine_version_incorrect(opts = {:exitstatus => true})
end
it "fails when the engine version doesn't match" do
- pending "we need to run this under jruby. can't simulate jruby with Kernel.exec inside `bundle exec`"
simulate_ruby_engine "jruby" do
gemfile <<-G
gem "rack", "0.9.1"

0 comments on commit 9efbcdf

Please sign in to comment.