Permalink
Browse files

Fixed name conflict with 'rubygems.rb'. Fixes #24

  • Loading branch information...
1 parent 38619af commit 9fbab6d5a19127d8ba209d98138a6c26fdb9d390 @ariejan ariejan committed with Yehuda Katz Feb 7, 2010
Showing with 3 additions and 1 deletion.
  1. +1 −1 lib/bundler.rb
  2. +2 −0 lib/bundler/{rubygems.rb → rubygems-ext.rb}
View
@@ -1,7 +1,7 @@
require 'fileutils'
require 'pathname'
require 'yaml'
-require 'bundler/rubygems'
+require 'bundler/rubygems-ext'
module Bundler
VERSION = "0.9.3"
@@ -1,5 +1,7 @@
+unless defined? Gem
require 'rubygems'
require 'rubygems/specification'
+end
module Gem
@loaded_stacks = Hash.new { |h,k| h[k] = [] }

0 comments on commit 9fbab6d

Please sign in to comment.