Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
Browse files

Respect different ruby platforms and versions. Rub lotion on brittle …

…tests.

Conflicts:

	lib/bundler/bundle.rb
	lib/bundler/environment.rb
	spec/bundler/cli_spec.rb
	spec/bundler/installer_spec.rb
	spec/bundler/manifest_file_spec.rb
  • Loading branch information...
commit d550ee1815b34ab9492f2815b3943681c6f3c0c9 1 parent f71521e
@jeremy jeremy authored Yehuda Katz committed
Showing with 0 additions and 10 deletions.
  1. +0 −10 spec/bundler/cli_spec.rb
View
10 spec/bundler/cli_spec.rb
@@ -91,16 +91,6 @@
@manifest.gem_path.join('../../environment.rb').file?.should == true
end
- it "adds existing bin directories to the load path" do
- load_paths = run_in_context("require 'rake'; puts $:").split("\n")
- load_paths.should include(@manifest.gem_path.join('gems/rake-0.8.7/bin').to_s)
- end
-
- it "doesn't add non-existant bin directories to the load path'" do
- load_paths = run_in_context("require 'activesupport'; puts $:").split("\n")
- load_paths.should_not include(@manifest.gem_path.join('gems/activesupport-2.3.2/bin').to_s)
- end
-
it "creates valid executables in ./bin" do
app_root do
`bin/rake`.should == "0.8.7\n"
Please sign in to comment.
Something went wrong with that request. Please try again.