Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
Browse files

Config is deprecated on 1.8.8 and 1.9.3, use RbConfig

  • Loading branch information...
commit dfe5d1058d942e670933e7b0c9b4d3ea54370fd3 1 parent 344b1c5
@spastorino spastorino authored
Showing with 2 additions and 1 deletion.
  1. +2 −1  lib/bundler.rb
View
3  lib/bundler.rb
@@ -1,3 +1,4 @@
+require 'rbconfig'
require 'fileutils'
require 'pathname'
require 'yaml'
@@ -185,7 +186,7 @@ def default_lockfile
SharedHelpers.default_lockfile
end
- WINDOWS = Config::CONFIG["host_os"] =~ %r!(msdos|mswin|djgpp|mingw)!
+ WINDOWS = RbConfig::CONFIG["host_os"] =~ %r!(msdos|mswin|djgpp|mingw)!
NULL = WINDOWS ? "NUL" : "/dev/null"
def requires_sudo?
Please sign in to comment.
Something went wrong with that request. Please try again.