Permalink
Browse files

require rbconfig, fixes #2382

  • Loading branch information...
1 parent 3ff82c6 commit f85a891362fe86e9b23bd4082dbbac67edd21367 @indirect indirect committed Mar 11, 2013
Showing with 1 addition and 0 deletions.
  1. +1 −0 lib/bundler/installer.rb
View
@@ -226,6 +226,7 @@ def generate_standalone(groups)
File.open File.join(bundler_path, "setup.rb"), "w" do |file|
+ file.puts "require 'rbconfig'"
file.puts "# ruby 1.8.7 doesn't define RUBY_ENGINE"
file.puts "ruby_engine = defined?(RUBY_ENGINE) ? RUBY_ENGINE : 'ruby'"
file.puts "ruby_version = RbConfig::CONFIG[\"ruby_version\"]"

0 comments on commit f85a891

Please sign in to comment.