Permalink
Commits on Aug 9, 2010
Commits on Jun 24, 2010
Commits on Jun 23, 2010
  1. Fix lockfile too new message

    indirect committed Jun 23, 2010
  2. Remove the current-checkout prefix from the load path before testing it.

    Without this change, a checkout of bundler to "bundler-0.9" (wherever in
    the absolute path) will avoid the check for older bundler versions (as it
    hits the _first_ bundler-0\.\d in the path.
    
    With this change, the test (and the failsafe as well) are made more solid,
    if not yet 100% perfect.
    Flameeyes committed with Andre Arko Jun 22, 2010
Commits on Jun 22, 2010
  1. Make the older-version warning slightly more solid.

    Without this change, this will also fail if you have a directory in path
    with a name such as 'bundler-0123456' (to mimick a git revision).
    Flameeyes committed with indirect Jun 22, 2010
  2. Make sure to only split by dashes the final part of the gem path.

    This avoids test failure (and bogus information reported by bundler) if the
    base path contains random dashes.
    Flameeyes committed with indirect Jun 22, 2010
  3. Avid failing the read-only test when running as root.

    Root users in most operating systems ignore the read-only permissions
    altogether; to avoid causing a failure if that's the case, simply mark the
    test as pending if executing as uid == 0.
    Flameeyes committed with indirect Jun 22, 2010
Commits on Jun 18, 2010
Commits on Jun 9, 2010
Commits on Jun 8, 2010
  1. Version 0.9.26

    indirect committed Jun 8, 2010
Commits on May 14, 2010
Commits on May 12, 2010
Commits on May 9, 2010
Commits on May 3, 2010
  1. Version 0.9.25

    indirect committed May 3, 2010
  2. Fix newlines in output from install command

    Closes #312
    indirect committed May 3, 2010
Commits on Apr 27, 2010
Commits on Apr 26, 2010
  1. Convert Pathname to String before passing it to Pathname.glob

    Apparently Pathname.glob is really picky in 1.9.1.
    
    Closes #303
    indirect committed Apr 26, 2010
Commits on Apr 23, 2010
  1. Make sure extra RUBYOPT args don't cause spec failures.

    This fixes the spec_gems_1_3_5 rake task.
    Brian Donovan committed with indirect Apr 22, 2010
Commits on Apr 22, 2010
  1. Version 0.9.24

    indirect committed Apr 22, 2010
  2. Make bundler work under Rubygems 1.3.5.

    This does not actually downgrade the required version of Rubygems,
    but does make it possible for brave souls who wish to override the
    restriction to do so.
    Brian Donovan committed with indirect Apr 22, 2010
  3. Fetch submodules for git sources

    Closes #299
    indirect committed Apr 22, 2010
  4. Sometimes gemspecs have absolute paths in them that are too long

    Rubygems can't handle building a gem if the path is too long, so we
    make the absolute paths in the gemspec relative and then it works
    indirect committed Apr 22, 2010
  5. Refactor arch spec a bit

    indirect committed Apr 22, 2010
Commits on Apr 21, 2010