bundle install asks to `bundle update` which asks to `bundle update` etc. #1020

jarmo opened this Issue Feb 7, 2011 · 3 comments


None yet

5 participants


I have a scenario where i had Gemfile.lock already generated by a Windows machine and then wanted to bundle install on a linux machine, but failed with the following message:
Fetching source index for http://rubygems.org/
You have requested:
nokogiri >= 0

The bundle currently has nokogiri locked at
Try running `bundle update nokogiri`    

After running bundle update nokogiri i get the same message as above. When looking into Gemfile.lock then there is this line for nokogiri:
nokogiri (

It seems that bundler doesn't know how to handle that one correctly. I deleted that line and bundle install succeeded.


I've also run into this issue, any new developments?


Is this still an issue?


This is a duplicate of #646 and can be closed.

@indirect indirect closed this Mar 27, 2013
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment