Skip to content
This repository

"Cannot load gem" error for Gemfile that lists curb #1060

Closed
myronmarston opened this Issue February 27, 2011 · 2 comments

2 participants

Myron Marston M. Scott Ford
Myron Marston

Given the following Gemfile:
source :rubygems

gem "curb", "~> 0.7.8"

And the following version of ruby:
$ ruby --version
ruby 1.8.7 (2010-12-23 patchlevel 330) [i686-darwin10.5.0]

And the following version of bundler:
$ bundle --version
Bundler version 1.0.10

When I run bundle install
Then I get the following error:

bundle install
Fetching source index for http://rubygems.org/
/Users/myron/.rvm/rubies/ruby-1.8.7-p330/lib/ruby/site_ruby/1.8/rubygems/format.rb:34:in `from_file_by_path': Cannot load gem at [/Users/myron/.rvm/gems/ruby-1.8.7-p330/cache/curb-0.7.12.gem] in /Users/myron/code/bundler_test (Gem::Exception)
    from /Users/myron/.rvm/gems/ruby-1.8.7-p330/gems/bundler-1.0.10/lib/bundler/source.rb:73:in `fetch'
    from /Users/myron/.rvm/gems/ruby-1.8.7-p330/gems/bundler-1.0.10/lib/bundler/installer.rb:45:in `run'
    from /Users/myron/.rvm/gems/ruby-1.8.7-p330/gems/bundler-1.0.10/lib/bundler/spec_set.rb:12:in `each'
    from /Users/myron/.rvm/gems/ruby-1.8.7-p330/gems/bundler-1.0.10/lib/bundler/spec_set.rb:12:in `each'
    from /Users/myron/.rvm/gems/ruby-1.8.7-p330/gems/bundler-1.0.10/lib/bundler/installer.rb:44:in `run'
    from /Users/myron/.rvm/gems/ruby-1.8.7-p330/gems/bundler-1.0.10/lib/bundler/installer.rb:8:in `install'
    from /Users/myron/.rvm/gems/ruby-1.8.7-p330/gems/bundler-1.0.10/lib/bundler/cli.rb:226:in `install'
    from /Users/myron/.rvm/gems/ruby-1.8.7-p330/gems/bundler-1.0.10/lib/bundler/vendor/thor/task.rb:22:in `send'
    from /Users/myron/.rvm/gems/ruby-1.8.7-p330/gems/bundler-1.0.10/lib/bundler/vendor/thor/task.rb:22:in `run'
    from /Users/myron/.rvm/gems/ruby-1.8.7-p330/gems/bundler-1.0.10/lib/bundler/vendor/thor/invocation.rb:118:in `invoke_task'
    from /Users/myron/.rvm/gems/ruby-1.8.7-p330/gems/bundler-1.0.10/lib/bundler/vendor/thor.rb:246:in `dispatch'
    from /Users/myron/.rvm/gems/ruby-1.8.7-p330/gems/bundler-1.0.10/lib/bundler/vendor/thor/base.rb:389:in `start'
    from /Users/myron/.rvm/gems/ruby-1.8.7-p330/gems/bundler-1.0.10/bin/bundle:13
    from /Users/myron/.rvm/gems/ruby-1.8.7-p330/bin/bundle:19:in `load'
    from /Users/myron/.rvm/gems/ruby-1.8.7-p330/bin/bundle:19

Has anyone else seen this?

Myron Marston

FWIW, it looks like if I specify an exact version of 0.7.8, then the installation works. Maybe it's a problem with curb 0.7.12?

Still, bundler should handle the issue (whatever it is) more gracefullly than this error message.

M. Scott Ford
Collaborator

It doesn't look like this failure is happening anymore. https://gist.github.com/4650217

M. Scott Ford mscottford closed this January 27, 2013
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.