Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

Already on GitHub? Sign in to your account

`bundle check` and `bundle install` command generate warning about #version_requirements #120

Closed
sikachu opened this Issue Feb 22, 2010 · 1 comment

Comments

Projects
None yet
2 participants

sikachu commented Feb 22, 2010

I've updated Bundler to 0.9.7 and RubyGems to 1.3.6, with Ruby 1.8.7-p249, and found out that when running bundle check or bundle install, this warning would be shown.

/Users/sikachu/.rvm/gems/ruby-1.8.7-p249/gems/bundler-0.9.7/lib/bundler/index.rb:79:Warning: Gem::Dependency#version_requirements is deprecated and will be removed on or after August 2010.  Use #requirement

I also see lots of this during running Rails test suit, probably when calling #setup ?

Thanks, and keep up a good work.

Owner

indirect commented Feb 22, 2010

This is #115.

@Koronen Koronen pushed a commit to Koronen/bundler that referenced this issue Aug 14, 2015

Carlhuda Use platform-independent path-separator. Closes #120 d794186

This issue was closed.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment