Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP

Loading…

Bundler.setup multiple times with different group sets breaks require #1230

Closed
drewinglis opened this Issue · 0 comments

2 participants

@drewinglis

bundler 1.0.14 on ruby 1.9.2p180

If I call Bundler.setup(:default), and then call Bundler.setup(:default, :some_additional_group), and then try to require a gem in default, I get a "no such file to load" error.

If you look at the attached gist, and run bundler_require.rb, it will require mocha ok, but break when it tries to require nokogiri.

https://gist.github.com/1015800

Let me know if you need any more info. =)

@indirect indirect closed this in bc92a7b
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.