Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP

Loading…

bundle viz fails #1708

Closed
resistorsoftware opened this Issue · 5 comments

3 participants

@resistorsoftware

Newest bundler gem, 1.1.0
Ruby 1.9.2-p290

bundle viz

/Users/doogie/.rvm/gems/ruby-1.9.2-p290/gems/bundler-1.1.0/lib/bundler/graph.rb:38:in block in _populate_relations': undefined methodto_spec' for #Bundler::Dependency:0x00000101337280 (NoMethodError)

@indirect
Owner

Can you please provide the information from ISSUES so we can try to reproduce this? Thanks.

@sijokg

It worked with bundler 1.0.22 But with bundler 1.2.0.pre.1 and 1.1.3 showed above specified error. I tried with ruby1.8.7

@indirect
Owner

Can you please provide the information from ISSUES so we can try to reproduce this? Thanks.

@sijokg

I created a gist. Could you please check it? I have not create a ticket in Bundler issue tracker. Please read from bottom of gist
https://gist.github.com/f1c33cbe00fb0bbc3edf

@indirect
Owner

Sorry, it worked perfectly for me with your exact Gemfile and Gemfile.lock on Ruby 1.8.7:

[andre ✘ ~/sw/gems/bundler-testcases/i1708](master⚡)$ ruby -v
ruby 1.8.7 (2012-02-08 patchlevel 358) [i686-darwin11.4.0]
[andre ✘ ~/sw/gems/bundler-testcases/i1708](master⚡)$ dbundle -v
Bundler version 1.2.0.pre.1
[andre ✘ ~/sw/gems/bundler-testcases/i1708](master⚡)$ dbundle viz
/Users/andre/sw/gems/bundler-testcases/i1708/gem_graph.png

Here's the graph:
gem_graph

@indirect indirect closed this
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.