Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP

Loading…

abort trap w/t error #1808

Closed
robbiecheng opened this Issue · 5 comments

3 participants

@robbiecheng

i got the following message w/t error
=> Bundling gems
Calculating dependencies...
Abort trap

my info is as follows:
ruby 1.8.6 (2010-09-02 patchlevel 420) [i686-darwin10.7.0]
bundler08 (0.8.5)
appengine-tools (0.0.16)

thanks,

@rohit
Collaborator

Hi can you refer to https://github.com/carlhuda/bundler/blob/master/ISSUES.md and provide more information? I'm afraid more information is needed to try and reproduce the problem.

@robbiecheng

i followed the doc, and did the clean up job, but got the following message

appcfg.rb update .
=> Bundling gems
Calculating dependencies...
Updating source: http://gems.rubyforge.org
/opt/local/lib/ruby/gems/1.8/gems/bundler08-0.8.5/lib/bundler08/resolver.rb:115:Warning: Gem::Dependency#version_requirements is deprecated and will be removed on or after August 2010. Use #requirement
Downloading addressable-2.2.7.gem
Downloading appengine-apis-0.0.35.gem
Caching: appengine-rack-0.0.13.gem
Downloading dm-appengine-0.1.3.gem
Downloading dm-core-1.2.0.gem
Downloading jruby-jars-1.5.6.gem
Downloading jruby-rack-1.0.4.gem
Downloading lexidecimal-0.0.1.gem
Downloading rack-1.4.1.gem
Downloading rack-protection-1.2.0.gem
Abort trap

thanks,

@rohit
Collaborator

No, what I meant was include more information by follow the Reporting Unresolved Problems section of that document.

A little googling found this http://stackoverflow.com/questions/6099496/rvm-ruby-abort-trap-segmentation-fault-switching-directories-and-doing-rvm-use

If you use RVM can you see if that fixes your problem? If no, then please do as above and include as much information as possible. If it did solve the problem then you can close this issue. Thanks! :)

@robbiecheng

No, we didn't use RVM. I've created a gist to provide my info, thanks.
https://gist.github.com/2302197

@xaviershay
Collaborator

Repro is from 1.8.6 which we don't support. Re-open with a repro on a recent ruby and bundler.

@xaviershay xaviershay closed this
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.