Skip to content
This repository

Gem::InstallError raised on bundle update #1833

Closed
dball opened this Issue April 10, 2012 · 2 comments

3 participants

Donald Ball Xavier Shay André Arko
Donald Ball
dball commented April 10, 2012
Installing factory_girl (3.1.0) Unfortunately, a fatal error has occurred. Please report this error to the Bundler issue tracker at https://github.com/carlhuda/bundler/issues so that we can fix it. Thanks!
/Users/dball/.rvm/rubies/ree-1.8.7-2012.02/lib/ruby/site_ruby/1.8/rubygems/installer.rb:388:in `ensure_required_ruby_version_met': factory_girl requires Ruby version >= 1.9.2. (Gem::InstallError)
    from /Users/dball/.rvm/rubies/ree-1.8.7-2012.02/lib/ruby/site_ruby/1.8/rubygems/installer.rb:156:in `install'
    from /Users/dball/.rvm/gems/ree-1.8.7-2012.02@decisiv/gems/bundler-1.1.0/lib/bundler/source.rb:90:in `install'
    from /Users/dball/.rvm/gems/ree-1.8.7-2012.02@decisiv/gems/bundler-1.1.0/lib/bundler/rubygems_integration.rb:82:in `preserve_paths'
    from /Users/dball/.rvm/gems/ree-1.8.7-2012.02@decisiv/gems/bundler-1.1.0/lib/bundler/source.rb:89:in `install'
    from /Users/dball/.rvm/gems/ree-1.8.7-2012.02@decisiv/gems/bundler-1.1.0/lib/bundler/installer.rb:73:in `install_gem_from_spec'
    from /Users/dball/.rvm/gems/ree-1.8.7-2012.02@decisiv/gems/bundler-1.1.0/lib/bundler/rubygems_integration.rb:97:in `with_build_args'
    from /Users/dball/.rvm/gems/ree-1.8.7-2012.02@decisiv/gems/bundler-1.1.0/lib/bundler/installer.rb:72:in `install_gem_from_spec'
    from /Users/dball/.rvm/gems/ree-1.8.7-2012.02@decisiv/gems/bundler-1.1.0/lib/bundler/installer.rb:56:in `run'
    from /Users/dball/.rvm/gems/ree-1.8.7-2012.02@decisiv/gems/bundler-1.1.0/lib/bundler/installer.rb:55:in `run'
    from /Users/dball/.rvm/gems/ree-1.8.7-2012.02@decisiv/gems/bundler-1.1.0/lib/bundler/installer.rb:12:in `install'
    from /Users/dball/.rvm/gems/ree-1.8.7-2012.02@decisiv/gems/bundler-1.1.0/lib/bundler/cli.rb:271:in `update'
    from /Users/dball/.rvm/gems/ree-1.8.7-2012.02@decisiv/gems/bundler-1.1.0/lib/bundler/vendor/thor/task.rb:22:in `send'
    from /Users/dball/.rvm/gems/ree-1.8.7-2012.02@decisiv/gems/bundler-1.1.0/lib/bundler/vendor/thor/task.rb:22:in `run'
    from /Users/dball/.rvm/gems/ree-1.8.7-2012.02@decisiv/gems/bundler-1.1.0/lib/bundler/vendor/thor/invocation.rb:118:in `invoke_task'
    from /Users/dball/.rvm/gems/ree-1.8.7-2012.02@decisiv/gems/bundler-1.1.0/lib/bundler/vendor/thor.rb:263:in `dispatch'
    from /Users/dball/.rvm/gems/ree-1.8.7-2012.02@decisiv/gems/bundler-1.1.0/lib/bundler/vendor/thor/base.rb:386:in `start'
    from /Users/dball/.rvm/gems/ree-1.8.7-2012.02@decisiv/gems/bundler-1.1.0/bin/bundle:13
    from /Users/dball/.rvm/gems/ree-1.8.7-2012.02@decisiv/bin/bundle:19:in `load'
    from /Users/dball/.rvm/gems/ree-1.8.7-2012.02@decisiv/bin/bundle:19

The error is legitimate, the Gemfile had no version constraint on factory_girl, and the latest versions do require ruby-1.9.x. While I suppose it might be nice if bundler took that into account when resolving the dependency graph, I'm really on reporting this because bundler asked so nicely.

André Arko
Owner

We'll try to come up with a prettier way to report errors like this, hopefully with less backtrace to wade through. Thanks for reporting!

Xavier Shay
Collaborator

These error messages are nicer now.

Xavier Shay xaviershay closed this August 11, 2013
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.