Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

Already on GitHub? Sign in to your account

bundle viz barfs on my MBP #1884

Closed
ep-wac opened this Issue Apr 30, 2012 · 1 comment

Comments

Projects
None yet
2 participants

ep-wac commented Apr 30, 2012

Hi,
upgraded my bundler - ('cause I really need the bundle viz command) - but it crumpled immediately. Here are the sordid details ;)

/Users/epwac/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubygems/dependency.rb:247:in `to_specs': Could not find nested_form (>= 0) amongst [POpen4-0.1.4, Platform-0.4.0, RedCloth-4.2.9, abstract-1.0.0, actionmailer-3.2.3, actionmailer-3.2.1, actionmailer-3.2.0, actionmailer-3.1.3, actionmailer-3.1.2, actionmailer-3.0.5, actionpack-3.2.3, actionpack-3.2.1, actionpack-3.2.0, actionpack-3.1.3, actionpack-3.1.2, actionpack-3.0.5, activemodel-3.2.3, activemodel-3.2.1, activemodel-3.2.0, activemodel-3.1.3, activemodel-3.1.2, activemodel-3.0.5, activerecord-3.2.3, activerecord-3.2.1, activerecord-3.2.0, activerecord-3.1.3, activerecord-3.1.2, activerecord-3.0.5, activeresource-3.2.3, activeresource-3.2.1, activeresource-3.2.0, activeresource-3.1.3, activeresource-3.1.2, activeresource-3.0.5, activesupport-3.2.3, activesupport-3.2.1, activesupport-3.2.0, activesupport-3.1.3, activesupport-3.1.2, activesupport-3.0.5, addressable-2.2.7, addressable-2.2.6, addressable-2.2.4, airbrake-3.0.9, ancestry-1.2.5, ancestry-1.2.4, ansi-1.4.2, ansi-1.4.1, app-routes-0.1.7, archive-tar-minitar-0.5.2, arel-3.0.2, arel-3.0.0, arel-2.2.1, arel-2.0.9, awesome_nested_fields-0.6.0, bcrypt-ruby-3.0.1, builder-3.0.0, builder-2.1.2, bundler-1.1.3, bundler-1.0.21, capybara-1.1.2, carrierwave-0.5.8, carrierwave-0.5.3, carrierwave_backgrounder-0.0.6, childprocess-0.3.2, childprocess-0.3.1, childprocess-0.2.8, chosen-rails-0.9.8, chronic-0.6.6, chronic_between-0.2.9, chunky_png-1.2.5, ckeditor_rails-3.6.2.2, coffee-filter-0.1.1, coffee-rails-3.2.2, coffee-rails-3.2.1, coffee-rails-3.1.1, coffee-script-2.2.0, coffee-script-source-1.3.1, coffee-script-source-1.2.0, columnize-0.3.6, columnize-0.3.2, commonjs-0.2.6, commonjs-0.2.5, commonjs-0.2.0, copycopter_client-2.0.0, cucumber-1.1.9, cucumber-1.1.4, cucumber-rails-1.3.0, cucumber-rails-1.2.1, cupsffi-0.0.5, daemon_controller-0.2.6, daemons-1.1.6, daemons-1.1.5, daemons-1.1.0, database_cleaner-0.7.2, database_cleaner-0.7.1, database_cleaner-0.7.0, delayed_job-3.0.0, delayed_job_active_record-0.3.1, devise-2.0.4, devise-2.0.1, devise-2.0.0, devise-1.5.3, devise_invitable-0.6.1, diff-lcs-1.1.3, dust-rails-0.3.0, eco-1.0.0, eco-source-1.1.0.rc.1, ejs-1.0.0, erubis-2.7.0, erubis-2.6.6, eventmachine-0.12.10, execjs-1.3.1, execjs-1.3.0, execjs-1.2.13, factory_girl-3.2.0, factory_girl-3.1.0, factory_girl-2.6.0, factory_girl-2.3.2, factory_girl_rails-3.2.0, factory_girl_rails-3.1.0, factory_girl_rails-1.7.0, factory_girl_rails-1.4.0, faraday-0.5.7, fastthread-1.0.7, ffi-1.0.11, fssm-0.2.8.1, geokit-1.6.5, geokit-rails3-0.1.5, gherkin-2.9.3, gherkin-2.9.0, gherkin-2.7.7, gherkin-2.7.2, growl-1.0.3, growl_notify-0.0.3, guard-1.0.1, guard-1.0.0, guard-cucumber-0.7.5, guard-rspec-0.7.0, guard-rspec-0.6.0, guard-spork-0.7.1, guard-spork-0.6.1, guard-spork-0.5.2, haml-3.1.4, haml-rails-0.3.4, has_scope-0.5.1, hike-1.2.1, hoptoad_notifier-2.4.11, i18n-0.6.0, i18n-0.5.0, ice_cube-0.8.0, inherited_resources-1.3.1, inherited_resources-1.3.0, jammit-0.6.5, journey-1.0.3, journey-1.0.1, journey-1.0.0, jquery-rails-2.0.2, jquery-rails-2.0.1, jquery-rails-2.0.0, jquery-rails-1.0.19, json-1.6.6, json-1.6.5, json-1.6.4, juggernaut-2.0.1, kaminari-0.13.0, launchy-2.1.0, launchy-2.0.5, less-2.2.1, less-2.1.0, less-2.0.9, less-2.0.8, less-rails-2.2.2, less-rails-2.2.0, less-rails-2.1.6, less-rails-2.1.3, less-rails-2.1.2, less-rails-bootstrap-1.4.3, libv8-3.3.10.4-x86_64-darwin-11, libwebsocket-0.1.3, linecache19-0.5.12, linecache19-0.5.11, liquid-2.3.0, liquify-0.2.7, mail-2.4.4, mail-2.4.1, mail-2.3.0, mail-2.2.15, mime-types-1.18, mime-types-1.17.2, mime-types-1.16, mini_magick-3.4, money-3.7.1, money-rails-0.1.0, money-rails-0.0.1, multi_json-1.3.2, multi_json-1.2.0, multi_json-1.1.0, multi_json-1.0.4, multi_json-0.0.5, multipart-post-1.1.0, mustache-0.99.4, mutter-0.5.3, mysql2-0.3.11, net-ldap-0.1.1, nokogiri-1.5.2, nokogiri-1.5.0, nokogiri-1.4.4, nordea-1.1.0, oa-basic-0.2.0, oa-core-0.2.0, oa-enterprise-0.2.0, oa-more-0.2.0, oa-oauth-0.2.0, oa-openid-0.2.0, oauth-0.4.4, oauth2-0.1.1, omniauth-0.2.0, open4-1.3.0, orm_adapter-0.0.7, orm_adapter-0.0.6, paper_trail-2.6.3, paper_trail-2.6.0, paper_trail-2.5.0, passenger-3.0.11, pg-0.12.2, polyamorous-0.5.0, polyglot-0.3.3, polyglot-0.3.1, pyu-ruby-sasl-0.0.3.2, rack-1.4.1, rack-1.4.0, rack-1.3.6, rack-1.2.2, rack-cache-1.2, rack-cache-1.1, rack-less-2.0.0, rack-mount-0.8.3, rack-mount-0.6.14, rack-openid-1.2.0, rack-raw-upload-1.0.11, rack-sprockets-1.1.0, rack-ssl-1.3.2, rack-test-0.6.1, rack-test-0.5.7, rails-3.2.3, rails-3.2.1, rails-3.2.0, rails-3.1.3, rails-3.1.2, rails-3.0.5, rails-erd-0.4.5, railties-3.2.3, railties-3.2.1, railties-3.2.0, railties-3.1.3, railties-3.1.2, railties-3.0.5, rake-0.9.2.2, rake-0.8.7, rake-remote_task-2.0.6, ransack-0.6.0, ransack-0.5.8, rb-appscript-0.6.1, rb-fsevent-0.9.1, rb-fsevent-0.9.0, rdiscount-1.6.8, rdoc-3.12, redis-2.1.1, responders-0.9.1, responders-0.6.5, responders-0.6.4, rest-client-1.6.1, rspec-2.9.0, rspec-2.8.0, rspec-core-2.9.0, rspec-core-2.8.0, rspec-expectations-2.9.1, rspec-expectations-2.8.0, rspec-mocks-2.9.0, rspec-mocks-2.8.0, rspec-rails-2.9.0, rspec-rails-2.8.1, ruby-debug-base19-0.11.25, ruby-debug-base19-0.11.24, ruby-debug19-0.11.6, ruby-graphviz-0.9.21, ruby-openid-2.1.8, ruby-openid-apps-discovery-1.2.0, ruby_core_source-0.1.5, ruby_core_source-0.1.4, ruby_gntp-0.3.4, rubygems-update-1.8.15, rubyntlm-0.1.1, rubyzip-0.9.8, rubyzip-0.9.7, rubyzip-0.9.6.1, rubyzip-0.9.5, sass-3.1.16, sass-3.1.15, sass-3.1.12, sass-rails-3.2.5, sass-rails-3.2.4, sass-rails-3.1.5, selenium-webdriver-2.21.2, selenium-webdriver-2.21.0, selenium-webdriver-2.20.0, selenium-webdriver-2.19.0, selenium-webdriver-2.18.0, selenium-webdriver-2.16.0, shoulda-2.11.3, shoulda-matchers-1.1.0, shoulda-matchers-1.0.0, simple_enum-1.5.1, simple_enum-1.5.0, simple_enum-1.4.1, simple_form-1.5.2, sinatra-1.1.0, spine-rails-0.1.0, spork-0.9.0, sprockets-2.1.3, sprockets-2.1.2, sprockets-2.0.3, sprockets-1.0.2, sqlite3-1.3.5, sqlite3-1.3.3, squeel-1.0.0, squeel-0.9.5, squeel-0.9.3, state_machine-1.1.2, state_machine-1.1.1, subexec-0.2.1, supermodel-0.1.4, term-ansicolor-1.0.7, therubyracer-0.10.1, therubyracer-0.9.10, therubyracer-0.9.9, thin-1.3.1, thin-1.2.11, thor-0.14.6, tilt-1.3.3, treetop-1.4.10, treetop-1.4.9, turn-0.8.2, twitter-bootstrap-rails-2.0.6, twitter-bootstrap-rails-2.0.3, twitter-bootstrap-rails-1.4.3, tzinfo-0.3.33, tzinfo-0.3.31, tzinfo-0.3.25, uglifier-1.2.4, uglifier-1.2.3, uglifier-1.2.2, uglifier-1.2.1, valium-0.4.0, vlad-2.2.5, vlad-2.2.4, vlad-git-2.2.0, warden-1.1.1, warden-1.1.0, watchr-0.7, will_paginate-3.0.3, will_paginate-3.0.2, xpath-0.1.4, yajl-ruby-1.1.0, yui-compressor-0.9.6, yui-compressor-0.9.4] (Gem::LoadError)
    from /Users/epwac/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubygems/dependency.rb:256:in `to_spec'
    from /Users/epwac/.rvm/gems/ruby-1.9.2-p290@oxenserver/gems/bundler-1.1.3/lib/bundler/graph.rb:38:in `block in _populate_relations'
    from /Users/epwac/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/1.9.1/set.rb:222:in `block in each'
    from /Users/epwac/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/1.9.1/set.rb:222:in `each_key'
    from /Users/epwac/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/1.9.1/set.rb:222:in `each'
    from /Users/epwac/.rvm/gems/ruby-1.9.2-p290@oxenserver/gems/bundler-1.1.3/lib/bundler/graph.rb:37:in `_populate_relations'
    from /Users/epwac/.rvm/gems/ruby-1.9.2-p290@oxenserver/gems/bundler-1.1.3/lib/bundler/graph.rb:18:in `initialize'
    from /Users/epwac/.rvm/gems/ruby-1.9.2-p290@oxenserver/gems/bundler-1.1.3/lib/bundler/cli.rb:519:in `new'
    from /Users/epwac/.rvm/gems/ruby-1.9.2-p290@oxenserver/gems/bundler-1.1.3/lib/bundler/cli.rb:519:in `viz'
    from /Users/epwac/.rvm/gems/ruby-1.9.2-p290@oxenserver/gems/bundler-1.1.3/lib/bundler/vendor/thor/task.rb:22:in `run'
    from /Users/epwac/.rvm/gems/ruby-1.9.2-p290@oxenserver/gems/bundler-1.1.3/lib/bundler/vendor/thor/invocation.rb:118:in `invoke_task'
    from /Users/epwac/.rvm/gems/ruby-1.9.2-p290@oxenserver/gems/bundler-1.1.3/lib/bundler/vendor/thor.rb:263:in `dispatch'
    from /Users/epwac/.rvm/gems/ruby-1.9.2-p290@oxenserver/gems/bundler-1.1.3/lib/bundler/vendor/thor/base.rb:386:in `start'
    from /Users/epwac/.rvm/gems/ruby-1.9.2-p290@oxenserver/gems/bundler-1.1.3/bin/bundle:13:in `<top (required)>'
    from /Users/epwac/.rvm/gems/ruby-1.9.2-p290@oxenserver/bin/bundle:19:in `load'
    from /Users/epwac/.rvm/gems/ruby-1.9.2-p290@oxenserver/bin/bundle:19:in `<main>'
[rails 3]

I've added my Gemfile :

# encoding: UTF-8
#/* - - - - - - - - - - - - - - - - - - - - -
#
#   Title : WEB Appliances Crest Inc, Web Form Framework
#   Author : Enrique Phillips 
#   URL : http://www.wac.bz
#
#- - - - - - - - - - - - - - - - - - - - - */
source 'http://rubygems.org'


gem 'rails' #, '3.2.0'
# Bundle edge Rails instead:
# gem 'rails',     :git => 'git://github.com/rails/rails.git'

#gem 'json'
gem 'yajl-ruby'
#gem 'thin'

gem 'mysql2'                                            # handle rDBMS

# building new/edit views with ease
#gem 'simple_form', :git => 'git://github.com/plataformatec/simple_form.git'                                       
gem 'simple_form', :git => 'git://github.com/plataformatec/simple_form.git', ref: '95f711366184cf38ebf9a571387ba5006114a40a'

gem 'paper_trail', '~> 2'                               # handle record versions

gem "devise"                                            # handling user authentication
# gem 'devise_invitable'                                  # and invitations to becoming a user

gem 'inherited_resources'                               # handling actions on controllers - abstracting controllers - providing urls like /projects/1/tasks

                                                        # Ernie Miller gem collection
gem "ransack"                                           # handling search in an easy way
gem "squeel"                                            # handle SQL with a human face :)
# gem 'valium'                                            # handling the use-case of getting single/few values from a few records (for selects etc)

gem "simple_enum"                                       # https://github.com/lwe/simple_enum
#gem 'will_paginate' #, '3.0.pre2'                       # paginate sql results
gem 'kaminari'

gem 'haml'
gem 'sass'
gem 'coffee-filter'                                     # handle coffeescript inside HAML - using :coffeescript

# building nested forms - like event/event_recurrences
gem 'nested_form', :git => 'git://github.com/ryanb/nested_form.git'
# gem 'awesome_nested_fields'

gem 'show_for', :git => 'git@github.com:wdiechmann/show_for.git'                        # building show views with ease

gem 'ancestry'                                          # handle tree structures

gem 'liquid'                                            # handling templating
gem 'liquify'                                           # making it easy on liquids
#gem 'RedCloth'                                          # and formatting text
gem "rdiscount"                                         # MarkDown HTML formatter
gem 'dust-rails'                                        # client-side templating made easy on the 'hands'

gem 'money', :git => 'https://github.com/RubyMoney/money.git' # handling money
gem 'money-rails'                                             # supporting the money gem - allows for monetize :price_cents
gem 'nordea', :git => 'git@github.com:ep-wac/nordea.git'      # and currencies

gem 'state_machine'                                     # handle states on classes

gem 'geokit-rails3'                                     # handling geo-location

gem 'ice_cube'                                          # handling schedules / recurring events

gem 'smt_rails', git: 'git://github.com/railsware/smt_rails.git'    # handle continous scrolling

gem 'ckeditor', '3.7.0.rc3'                             # handle text field editing
gem 'chosen-rails'                                      # handle select boxes

gem 'carrierwave'                                       # handling file uploads
gem 'mini_magick'                                       # handle image post processing (scaling|cropping|etc) - gem "rmagick" substitute

#
# TODO 2012-03-25 translations are not ready for production yet -  neither Redis nor CopyCopter makes the cut
#
# gem "redis"                                            # used for storing I18n translations
# gem 'copycopter_client', '2.0.0'                        # ditto

# gem "sinatra", "1.1.0", :require => "sinatra/base"

# 
# gem 'has_scope'                       # handling queries on controllers - matching scopes on models - applying scopes as params in querystrings
# 
# 
# 
# 
# 
# 
# #gem "vidibus-routing_error"          # Rails 3.1 does not handle routing errors 'out-of-the-box' 
#                                       # but vidibus-routing_error touches on the session data somehow - 
# 
# # 2011-11-18 TODO due to https://github.com/bcardarella/client_side_validations/issues/146
# # client side validations are postponed until further!
# # gem 'client_side_validations'         # handling client side validations (in javascript)
# 
# gem 'delayed_job'                     # handle 'delayed' - ie asynchronous calls
# gem 'delayed_job_active_record'       # use 'delayed_job' with Active Record
# gem "daemons"                         # handle 'delayed_job' in background
# 
# gem 'carrierwave_backgrounder'        # process image in background - using DelayedJob
# 
# gem 'rack-raw-upload'                 # handle large file uploads
# 
# 
# 
# 
# gem 'chronic'                         # handling natural language dates - like 8am tomorrow
# gem 'chronic_between'                 # handling natural language ranges - like 7:00-15:45;not Saturday-Sunday
# 
# gem 'cupsffi'                         # handling CUPS printing
# 



gem 'therubyracer'

# Gems used only in development
group :development do
  gem 'ruby_gntp'                         # sending notifications via GNTP
    gem 'vlad'
  gem 'vlad-git'
  # gem 'haml-rails', '>= 0.3.4'
  # gem 'hanna' - for documentation, but not ready for rake 0.9.2 et al
    # To use debugger
  gem 'ruby-debug19', :require => 'ruby-debug'
  gem "rails-erd"                                       # draw ER diagrams
end

group :development, :test do 
  #gem "shoulda"                                         # great matchers for associations
  gem 'rspec-rails', ">= 2.6.1"
  gem 'shoulda-matchers'
  gem 'launchy'  
  gem 'database_cleaner'  
  gem 'rb-fsevent', :require => false if RUBY_PLATFORM =~ /darwin/i  
  gem "guard-spork"
  gem 'guard-rspec'  
  gem "guard-cucumber"
end

# Gems used only for assets and not required
# in production environments by default.
group :assets do
  # gem 'less',       git: 'git://github.com/petejkim/less.rb.git', submodules: true
  # gem 'less-rails' #, '~> 2.1.2'
  # gem 'less-rails-bootstrap' #, '~>1.3.0'
  gem 'twitter-bootstrap-rails'
  gem 'sass-rails'    #,   '~> 3.2.3'
  gem 'coffee-rails'  #, '~> 3.2.1'
  gem 'uglifier'      #,  '>= 1.0.3'

end

gem 'jquery-rails'


# To use ActiveModel has_secure_password
# gem 'bcrypt-ruby', '~> 3.0.0'

# Use unicorn as the web server
# gem 'unicorn'

# Deploy with Capistrano
# gem 'capistrano'

# To use debugger
# gem 'ruby-debug19', :require => 'ruby-debug'

group :test do
  # Pretty printed test output
  gem 'turn', '0.8.2', :require => false
  gem 'factory_girl_rails'    
  gem 'capybara'                                #, :git => 'git://github.com/jnicklas/capybara.git'  
  gem 'cucumber-rails'
  gem 'spork', '~> 0.9.0.rc'
end

and the Gemfile.lock too

 GIT
   remote: git://github.com/plataformatec/simple_form.git
   revision: 95f711366184cf38ebf9a571387ba5006114a40a
   ref: 95f711366184cf38ebf9a571387ba5006114a40a
   specs:
     simple_form (2.0.0.dev)
       actionpack (~> 3.0)
       activemodel (~> 3.0)

 GIT
   remote: git://github.com/railsware/smt_rails.git
   revision: 8e543259ecf202aa0bdeb93500da04dcbcd16ef5
   specs:
     smt_rails (0.2.0)
       mustache (>= 0.99.4)
       rails (>= 3.1.0)
       sprockets (>= 2.0.3)
       tilt (>= 1.3.3)

 GIT
   remote: git://github.com/ryanb/nested_form.git
   revision: 63dcbcc6c6dbe07b3761ae8cc0cd04cc2a45024a
   specs:
     nested_form (0.2.0)

 GIT
   remote: git@github.com:ep-wac/nordea.git
   revision: f722985a4c201234069b51281264c2e9633164b1
   specs:
     nordea (1.1.0)
       money
       tzinfo (~> 0.3.28)

 GIT
   remote: git@github.com:wdiechmann/show_for.git
   revision: 05fa3bdc541d71f88b992666553a9501e65fbcc6
   specs:
     show_for (0.2.4)

 GIT
   remote: https://github.com/RubyMoney/money.git
   revision: ef45c615008a7e74a88524f26d07955f0f9b4943
   specs:
     money (5.0.0)
       i18n (~> 0.4)
       json

 GEM
   remote: http://rubygems.org/
   specs:
     actionmailer (3.2.3)
       actionpack (= 3.2.3)
       mail (~> 2.4.4)
     actionpack (3.2.3)
       activemodel (= 3.2.3)
       activesupport (= 3.2.3)
       builder (~> 3.0.0)
       erubis (~> 2.7.0)
       journey (~> 1.0.1)
       rack (~> 1.4.0)
       rack-cache (~> 1.2)
       rack-test (~> 0.6.1)
       sprockets (~> 2.1.2)
     activemodel (3.2.3)
       activesupport (= 3.2.3)
       builder (~> 3.0.0)
     activerecord (3.2.3)
       activemodel (= 3.2.3)
       activesupport (= 3.2.3)
       arel (~> 3.0.2)
       tzinfo (~> 0.3.29)
     activeresource (3.2.3)
       activemodel (= 3.2.3)
       activesupport (= 3.2.3)
     activesupport (3.2.3)
       i18n (~> 0.6)
       multi_json (~> 1.0)
     addressable (2.2.7)
     ancestry (1.2.5)
       activerecord (>= 2.2.2)
     ansi (1.4.2)
     archive-tar-minitar (0.5.2)
     arel (3.0.2)
     bcrypt-ruby (3.0.1)
     builder (3.0.0)
     capybara (1.1.2)
       mime-types (>= 1.16)
       nokogiri (>= 1.3.3)
       rack (>= 1.0.0)
       rack-test (>= 0.5.4)
       selenium-webdriver (~> 2.0)
       xpath (~> 0.1.4)
     childprocess (0.3.2)
       ffi (~> 1.0.6)
     chosen-rails (0.9.8)
       railties (~> 3.0)
       thor (~> 0.14)
     ckeditor_rails (3.6.2.2)
       railties (~> 3.0)
       thor (~> 0.14)
     coffee-filter (0.1.1)
       coffee-script (>= 2.2.0)
       haml (>= 3.0.18)
     coffee-rails (3.2.2)
       coffee-script (>= 2.2.0)
       railties (~> 3.2.0)
     coffee-script (2.2.0)
       coffee-script-source
       execjs
     coffee-script-source (1.3.1)
     columnize (0.3.6)
     commonjs (0.2.6)
     cucumber (1.1.9)
       builder (>= 2.1.2)
       diff-lcs (>= 1.1.2)
       gherkin (~> 2.9.0)
       json (>= 1.4.6)
       term-ansicolor (>= 1.0.6)
     cucumber-rails (1.3.0)
       capybara (>= 1.1.2)
       cucumber (>= 1.1.8)
       nokogiri (>= 1.5.0)
     database_cleaner (0.7.2)
     devise (2.0.4)
       bcrypt-ruby (~> 3.0)
       orm_adapter (~> 0.0.3)
       railties (~> 3.1)
       warden (~> 1.1.1)
     diff-lcs (1.1.3)
     dust-rails (0.3.0)
       execjs
       rails (> 3.1.0)
       tilt
     erubis (2.7.0)
     execjs (1.3.1)
       multi_json (~> 1.0)
     factory_girl (3.2.0)
       activesupport (>= 3.0.0)
     factory_girl_rails (3.2.0)
       factory_girl (~> 3.2.0)
       railties (>= 3.0.0)
     ffi (1.0.11)
     geokit (1.6.5)
       multi_json
     geokit-rails3 (0.1.5)
       geokit (~> 1.5)
       rails (~> 3.0)
     gherkin (2.9.3)
       json (>= 1.4.6)
     guard (1.0.1)
       ffi (>= 0.5.0)
       thor (~> 0.14.6)
     guard-cucumber (0.7.5)
       cucumber (>= 0.10)
       guard (>= 0.8.3)
     guard-rspec (0.7.0)
       guard (>= 0.10.0)
     guard-spork (0.7.1)
       guard (>= 0.10.0)
       spork (>= 0.8.4)
     haml (3.1.4)
     has_scope (0.5.1)
     hike (1.2.1)
     i18n (0.6.0)
     ice_cube (0.8.0)
     inherited_resources (1.3.1)
       has_scope (~> 0.5.0)
       responders (~> 0.6)
     journey (1.0.3)
     jquery-rails (2.0.2)
       railties (>= 3.2.0, < 5.0)
       thor (~> 0.14)
     json (1.6.6)
     kaminari (0.13.0)
       actionpack (>= 3.0.0)
       activesupport (>= 3.0.0)
       railties (>= 3.0.0)
     launchy (2.1.0)
       addressable (~> 2.2.6)
     less (2.2.1)
       commonjs (~> 0.2.6)
     less-rails (2.2.2)
       actionpack (>= 3.1)
       less (~> 2.2.0)
     libv8 (3.3.10.4)
     libwebsocket (0.1.3)
       addressable
     linecache19 (0.5.12)
       ruby_core_source (>= 0.1.4)
     liquid (2.3.0)
     liquify (0.2.7)
       liquid (>= 2.2.2)
     mail (2.4.4)
       i18n (>= 0.4.0)
       mime-types (~> 1.16)
       treetop (~> 1.4.8)
     mime-types (1.18)
     money-rails (0.1.0)
       activesupport (~> 3.0)
       money (~> 5.0.0)
       railties (~> 3.0)
     multi_json (1.3.2)
     mustache (0.99.4)
     mysql2 (0.3.11)
     nokogiri (1.5.2)
     open4 (1.3.0)
     orm_adapter (0.0.7)
     paper_trail (2.6.3)
       activerecord (~> 3.0)
       railties (~> 3.0)
     polyamorous (0.5.0)
       activerecord (~> 3.0)
     polyglot (0.3.3)
     rack (1.4.1)
     rack-cache (1.2)
       rack (>= 0.4)
     rack-ssl (1.3.2)
       rack
     rack-test (0.6.1)
       rack (>= 1.0)
     rails (3.2.3)
       actionmailer (= 3.2.3)
       actionpack (= 3.2.3)
       activerecord (= 3.2.3)
       activeresource (= 3.2.3)
       activesupport (= 3.2.3)
       bundler (~> 1.0)
       railties (= 3.2.3)
     rails-erd (0.4.5)
       activerecord (~> 3.0)
       activesupport (~> 3.0)
       ruby-graphviz (~> 0.9.18)
     railties (3.2.3)
       actionpack (= 3.2.3)
       activesupport (= 3.2.3)
       rack-ssl (~> 1.3.2)
       rake (>= 0.8.7)
       rdoc (~> 3.4)
       thor (~> 0.14.6)
     rake (0.9.2.2)
     rake-remote_task (2.0.6)
       open4 (~> 1.0)
       rake (~> 0.8)
     ransack (0.6.0)
       actionpack (~> 3.0)
       activerecord (~> 3.0)
       polyamorous (~> 0.5.0)
     rb-fsevent (0.9.1)
     rdiscount (1.6.8)
     rdoc (3.12)
       json (~> 1.4)
     responders (0.9.1)
       railties (~> 3.1)
     rspec (2.9.0)
       rspec-core (~> 2.9.0)
       rspec-expectations (~> 2.9.0)
       rspec-mocks (~> 2.9.0)
     rspec-core (2.9.0)
     rspec-expectations (2.9.1)
       diff-lcs (~> 1.1.3)
     rspec-mocks (2.9.0)
     rspec-rails (2.9.0)
       actionpack (>= 3.0)
       activesupport (>= 3.0)
       railties (>= 3.0)
       rspec (~> 2.9.0)
     ruby-debug-base19 (0.11.25)
       columnize (>= 0.3.1)
       linecache19 (>= 0.5.11)
       ruby_core_source (>= 0.1.4)
     ruby-debug19 (0.11.6)
       columnize (>= 0.3.1)
       linecache19 (>= 0.5.11)
       ruby-debug-base19 (>= 0.11.19)
     ruby-graphviz (0.9.21)
     ruby_core_source (0.1.5)
       archive-tar-minitar (>= 0.5.2)
     ruby_gntp (0.3.4)
     rubyzip (0.9.8)
     sass (3.1.16)
     sass-rails (3.2.5)
       railties (~> 3.2.0)
       sass (>= 3.1.10)
       tilt (~> 1.3)
     selenium-webdriver (2.21.2)
       childprocess (>= 0.2.5)
       ffi (~> 1.0)
       libwebsocket (~> 0.1.3)
       multi_json (~> 1.0)
       rubyzip
     shoulda-matchers (1.1.0)
       activesupport (>= 3.0.0)
     simple_enum (1.5.1)
       activesupport (>= 3.0.0)
     spork (0.9.0)
     sprockets (2.1.3)
       hike (~> 1.2)
       rack (~> 1.0)
       tilt (~> 1.1, != 1.3.0)
     squeel (1.0.0)
       activerecord (~> 3.0)
       activesupport (~> 3.0)
       polyamorous (~> 0.5.0)
     state_machine (1.1.2)
     term-ansicolor (1.0.7)
     therubyracer (0.10.1)
       libv8 (~> 3.3.10)
     thor (0.14.6)
     tilt (1.3.3)
     treetop (1.4.10)
       polyglot
       polyglot (>= 0.3.1)
     turn (0.8.2)
       ansi (>= 1.2.2)
     twitter-bootstrap-rails (2.0.6)
       actionpack (>= 3.1)
       less-rails (~> 2.2.0)
       railties (>= 3.1)
     tzinfo (0.3.33)
     uglifier (1.2.4)
       execjs (>= 0.3.0)
       multi_json (>= 1.0.2)
     vlad (2.2.5)
       rake (~> 0.8)
       rake-remote_task (~> 2.0)
     vlad-git (2.2.0)
       vlad (>= 2.1.0)
     warden (1.1.1)
       rack (>= 1.0)
     xpath (0.1.4)
       nokogiri (~> 1.3)
     yajl-ruby (1.1.0)

 PLATFORMS
   ruby

 DEPENDENCIES
   ancestry
   capybara
   chosen-rails
   ckeditor_rails
   coffee-filter
   coffee-rails
   cucumber-rails
   database_cleaner
   devise
   dust-rails
   factory_girl_rails
   geokit-rails3
   guard-cucumber
   guard-rspec
   guard-spork
   haml
   ice_cube
   inherited_resources
   jquery-rails
   kaminari
   launchy
   liquid
   liquify
   money!
   money-rails
   mysql2
   nested_form!
   nordea!
   paper_trail (~> 2)
   rails
   rails-erd
   ransack
   rb-fsevent
   rdiscount
   rspec-rails (>= 2.6.1)
   ruby-debug19
   ruby_gntp
   sass
   sass-rails
   shoulda-matchers
   show_for!
   simple_enum
   simple_form!
   smt_rails!
   spork (~> 0.9.0.rc)
   squeel
   state_machine
   therubyracer
   turn (= 0.8.2)
   twitter-bootstrap-rails
   uglifier
   vlad
   vlad-git
   yajl-ruby

and finally the rvm info

ruby-1.9.2-p290@oxenserver:

  system:
    uname:       "Darwin MacEPWAC.local 11.3.0 Darwin Kernel Version 11.3.0: Thu Jan 12 18:47:41 PST 2012; root:xnu-1699.24.23~1/RELEASE_X86_64 x86_64"
    bash:        "/bin/bash => GNU bash, version 3.2.48(1)-release (x86_64-apple-darwin11)"
    zsh:         "/bin/zsh => zsh 4.3.11 (i386-apple-darwin11.0)"

  rvm:
    version:      "rvm 1.8.3 by Wayne E. Seguin (wayneeseguin@gmail.com) [https://rvm.beginrescueend.com/]"

  ruby:
    interpreter:  "ruby"
    version:      "1.9.2p290"
    date:         "2011-07-09"
    platform:     "x86_64-darwin11.1.0"
    patchlevel:   "2011-07-09 revision 32553"
    full_version: "ruby 1.9.2p290 (2011-07-09 revision 32553) [x86_64-darwin11.1.0]"

  homes:
    gem:          "/Users/epwac/.rvm/gems/ruby-1.9.2-p290@oxenserver"
    ruby:         "/Users/epwac/.rvm/rubies/ruby-1.9.2-p290"

  binaries:
    ruby:         "/Users/epwac/.rvm/rubies/ruby-1.9.2-p290/bin/ruby"
    irb:          "/Users/epwac/.rvm/rubies/ruby-1.9.2-p290/bin/irb"
    gem:          "/Users/epwac/.rvm/rubies/ruby-1.9.2-p290/bin/gem"
    rake:         "/Users/epwac/.rvm/gems/ruby-1.9.2-p290@oxenserver/bin/rake"

  environment:
    PATH:         "/Users/epwac/.rvm/gems/ruby-1.9.2-p290@oxenserver/bin:/Users/epwac/.rvm/gems/ruby-1.9.2-p290@global/bin:/Users/epwac/.rvm/rubies/ruby-1.9.2-p290/bin:/Users/epwac/.rvm/bin:~/bin:/usr/bin:/bin:/usr/sbin:/sbin:/usr/local/bin:/usr/X11/bin:/usr/local/MacGPG2/bin:/Users/epwac/.rip/active/bin"
    GEM_HOME:     "/Users/epwac/.rvm/gems/ruby-1.9.2-p290@oxenserver"
    GEM_PATH:     "/Users/epwac/.rvm/gems/ruby-1.9.2-p290@oxenserver:/Users/epwac/.rvm/gems/ruby-1.9.2-p290@global"
    MY_RUBY_HOME: "/Users/epwac/.rvm/rubies/ruby-1.9.2-p290"
    IRBRC:        "/Users/epwac/.rvm/rubies/ruby-1.9.2-p290/.irbrc"
    RUBYOPT:      ""
    gemset:       "oxenserver"
Contributor

rohit commented Nov 14, 2012

Closing as this is a duplicate of carlhuda#1762

There is a PR (carlhuda#2046) to fix this issue. Can you please test the patch and give feedback?

@rohit rohit closed this Nov 14, 2012

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment