Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP

Loading…

Strange error on jruby 1.8 mode #1995

Closed
stereobooster opened this Issue · 1 comment

2 participants

stereobooster Xavier Shay
stereobooster
$ ruby --version
11jruby 1.6.7.2 (ruby-1.8.7-p357) (2012-05-01 26e08ba) (OpenJDK Server VM 1.7.0_147-icedtea) [linux-i386-java]
12$ gem --version
131.8.24
14$ export BUNDLE_GEMFILE=/home/vagrant/builds/stereobooster/css_press/Gemfile
15$ bundle install
27Your bundle is complete! Use `bundle show [gemname]` to see where a bundled gem is installed.
28$ bundle exec rake
29/home/vagrant/.rvm/gems/jruby-1.6.7.2@global/gems/bundler-1.1.4/lib/bundler/source.rb:19:in `initialize': (RegexpError) null: /\/$/ (SyntaxError)
30       /home/vagrant/.rvm/gems/jruby-1.6.7.2@global/gems/bundler-1.1.4/lib/bundler/dsl.rb:6:in `evaluate'
31       /home/vagrant/.rvm/gems/jruby-1.6.7.2@global/gems/bundler-1.1.4/lib/bundler/definition.rb:18:in `build'
32       /home/vagrant/.rvm/gems/jruby-1.6.7.2@global/gems/bundler-1.1.4/lib/bundler.rb:135:in `definition'
33       /home/vagrant/.rvm/gems/jruby-1.6.7.2@global/gems/bundler-1.1.4/lib/bundler.rb:123:in `load'
34       /home/vagrant/.rvm/gems/jruby-1.6.7.2@global/gems/bundler-1.1.4/lib/bundler/cli.rb:400:in `exec'
35       org/jruby/RubyKernel.java:2080:in `send'
36       /home/vagrant/.rvm/gems/jruby-1.6.7.2@global/gems/bundler-1.1.4/lib/bundler/vendor/thor/task.rb:21:in `run'
37       /home/vagrant/.rvm/gems/jruby-1.6.7.2@global/gems/bundler-1.1.4/lib/bundler/vendor/thor/invocation.rb:118:in `invoke_task'
38       /home/vagrant/.rvm/gems/jruby-1.6.7.2@global/gems/bundler-1.1.4/lib/bundler/vendor/thor.rb:263:in `dispatch'
39       /home/vagrant/.rvm/gems/jruby-1.6.7.2@global/gems/bundler-1.1.4/lib/bundler/vendor/thor/base.rb:386:in `start'
40       /home/vagrant/.rvm/gems/jruby-1.6.7.2@global/gems/bundler-1.1.4/bin/bundle:13:in `(root)'
41       org/jruby/RubyKernel.java:1058:in `load'
42       /home/vagrant/.rvm/gems/jruby-1.6.7.2@global/bin/bundle:23:in `(root)'
43There was an error in your Gemfile, and Bundler cannot continue.

Of course there can't be an error in Gemfile, because bundle install works

details here http://travis-ci.org/#!/stereobooster/css_press/builds/1653993

Xavier Shay
Collaborator

Looks like a jruby bug, please file with those guys if this is still an issue.

Xavier Shay xaviershay closed this
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.