bundle install --deployment ignores rvm #2174

Closed
wildchild opened this Issue Nov 21, 2012 · 8 comments

Comments

Projects
None yet
4 participants
$ gem --version
1.8.24

ruby --version
ruby 1.9.3p327 (2012-11-10 revision 37606) [x86_64-darwin12.2.0]

bundle install --deployment --verbose

Installing liquid (2.4.1)
Gem::InstallError: liquid requires RubyGems version >= 1.3.7. Try 'gem update --system' to update RubyGems itself.
/System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/1.8/rubygems/installer.rb:169:in `install'

Owner

indirect commented Nov 21, 2012

Please see ISSUES

On Nov 21, 2012, at 8:28 AM, Alexander Uvarov notifications@github.com wrote:

$ gem --version
1.8.24

ruby --version
ruby 1.9.3p327 (2012-11-10 revision 37606) [x86_64-darwin12.2.0]

bundle install --deployment --verbose
Installing liquid (2.4.1)
Gem::InstallError: liquid requires RubyGems version >= 1.3.7. Try 'gem update --system' to update RubyGems itself.
/System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/1.8/rubygems/installer.rb:169:in `install'


Reply to this email directly or view it on GitHub.

conatus commented Jan 2, 2013

I am having the same error. The problems are as follows https://gist.github.com/4435210

Thanks a lot!

Owner

indirect commented Jan 2, 2013

@conatus please read the error message. you're trying to install Liquid onto a version of Rubygems that is too old. This isn't a Bundler bug.

indirect closed this Jan 2, 2013

conatus commented Jan 3, 2013

Sorry, the problem is that though I clearly have gem version 1.8.4 installed, Liquid (when being installed within Bundler) is still returning that the version that is installed is too old. Therefore somewhere Bundler is causing the problem here, as I can install it fine directly.

› gem install liquid
Successfully installed liquid-2.4.1
1 gem installed
Installing ri documentation for liquid-2.4.1...
Installing RDoc documentation for liquid-2.4.1...
Owner

indirect commented Jan 3, 2013

Try running "head which bundle" To see which ruby you're getting. Bundler can't change your rubygems version, but the Bundler executable created by rubygems might be able to.

On Jan 2, 2013, at 11:16 PM, Alex notifications@github.com wrote:

Sorry, the problem is that though I clearly have gem version 1.8.4 installed, Liquid is still returning that the version that is installed is too old. Therefore somewhere Bundler is causing the problem here, as I can install it fine directly.

› gem install liquid
Successfully installed liquid-2.4.1
1 gem installed
Installing ri documentation for liquid-2.4.1...
Installing RDoc documentation for liquid-2.4.1...

Reply to this email directly or view it on GitHub.

conatus commented Jan 3, 2013

Thanks for your continued help.

This is claiming /System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/bin/ruby there.

So the problem is somewhere upstream about rbenv and things getting confused here? Do I need to uninstall bundler and reinstall locally for rbenv?

Owner

indirect commented Jan 3, 2013

What is the output from which bundler? If its in your rbenv ruby's gems, uninstall and reinstall Bundler. If it's in /System/Library, install Bundler for your rbenv ruby.

On Jan 2, 2013, at 11:48 PM, Alex notifications@github.com wrote:

Thanks for your continued help.

This is claiming /System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/bin/ruby there.

So the problem is somewhere upstream about rbenv and things getting confused here? Do I need to uninstall bundler and reinstall locally for rbenv?


Reply to this email directly or view it on GitHub.

matlux commented Apr 30, 2014

Hi,
I just had the same issue and managed to solve it.

which bundle
=> /usr/bin/bundle which was the old 1.8 bundle.

I removed

mv /usr/bin/bundle /usr/bin/bundle-old

ran:

rbenv rehash
which bundle
=> /usr/local/var/rbenv/shims/bundle (this is the 1.9 bundle installed by rbenv gem)

reran:

bundle install

It worked.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment