Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP

Loading…

Already activated when using bundle exec. #2216

Closed
pschuegr opened this Issue · 4 comments

2 participants

@pschuegr

I apologize if my understanding is flawed, but I don't understand a problem that I'm having.

My Gemfile specifies rails-3.2.8, and the rspec-dump-profile-customizer gem requires rails >= 3.0.0.

However, when I try and execute 'bundle exec rspec' with this gem installed, it grabs the 3.2.8 which I have installed on my system and I get this:

/home/paul/.rvm/gems/ruby-1.9.3-p194/gems/bundler-1.2.3/lib/bundler/runtime.rb:31:in `block in setup': You have already activated activesupport 3.2.8, but your Gemfile requires activesupport 3.2.6. Using bundle exec may solve this. (Gem::LoadError)

It seems to come from this section:

require 'rails/engine'
require 'rspec/core/formatters/base_formatter'
require 'rspec/core/formatters/documentation_formatter'

So it seems that when it requires 'rails/engine', it's looking to the system gems before the bundled gems. Is this as it should be?

@indirect
Owner

Please provide the rest of the information requested in IISSUES. Thanks!

@pschuegr

https://gist.github.com/4322118

Thanks!

Update: looks like it has something to do with using gems with the :git or :path location. When I use the published version of the rspec-dump-profile-customizer gem, it seems to work fine.

@indirect
Owner

@pschuegr unfortunately, I can't try to reproduce this problem, since your gemfile contains many private repos. If you could narrow down the gems that cause the problem, I would be happy to investigate.

@pschuegr

Ah right. I'll try and do this when I have a chance, thanks for looking into it.

@pschuegr pschuegr closed this
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.