'bundle install' is not showing which dependency is unresolvable #227

Closed
thewoolleyman opened this Issue Mar 29, 2010 · 2 comments

Comments

Projects
None yet
2 participants

With bundler 0.9.13:

No compatible versions could be found for required dependencies:
Conflict on: "hpricot":
* hpricot (0.6.164) activated by hpricot (= 0.6.164, runtime)
* hpricot (= 0.8.2, runtime) required by
All possible versions of origin requirements conflict.

Notice that there is nothing after "required by"

Here's the Gemfile:

source :gemcutter
gem "geminstaller", ">= 0.5.3"
gem "rails", "2.2.2"
gem "ZenTest", "3.4.3"
gem "capistrano", ">= 2.2.0"
gem "capistrano-ext", "1.2.0"
gem "diff-lcs", "1.1.2"
gem "flexmock", "0.6.2"
gem "hpricot", "0.6.164"
gem "json", "1.1.0"
gem "log4r", "1.0.6"
gem "mongrel", ">= 1.1.4"
gem "mongrel_cluster", "1.0.5"
gem "needle", "1.3.0"
gem "tzinfo", "0.3.13"
gem "mime-types", ">= 1.15"
gem "aws-s3", "0.3.0"
gem "builder", "2.1.2"
gem "xml-simple", ">= 1.0.11"
gem "money", "1.7.1"
gem "delayed_job", "> 1.8.4"
gem "mysql", ">=2.7"
gem "rdiscount", ">= 1.3.4"
gem "fastercsv", "1.5.0"
gem "gruff", "0.3.1"
gem "mocha", "0.9.8"
gem "newrelic_rpm", ">= 2.9.4"
gem "will_paginate", "2.2.2"
gem "polonium", "0.3.3"
gem "selenium-client", ">= 1.2.17"
gem "lsof", "0.3.0"
gem "selenium-rc", "2.1.0"
gem "hpricot", "= 0.8.2"
gem "thewoolleyman-simple-daemon", ">= 0.1.3"
gem "activemerchant", "1.4.1"
gem "rack", ">= 0.9.1"
gem "nokogiri", ">=1.3.2"
gem "engineyard-eycap", "
> 0.4.15"
gem "saucelabs-adapter", "0.8.2"
gem "twitter", "0.6.14"
gem "rspec-rails", ">= 1.2.6"
gem "rspec", ">= 1.2.6"
gem "hoptoad_notifier", "2.1.3"
gem "bitly", "0.4.0"
gem "sparklines", ">= 0.5.2"
gem "lighthouse-api", "1.1.0"
gem "soap4r", "1.5.8"
gem "jira4r", "0.3.0"
gem "ruby-satisfaction", "0.4.2"
gem "tinder", "1.3.1"

DOH, I've got hpricot listed twice. Still, this error message should be improved.

It should say something like "hpricot (= 0.8.2, runtime) required directly by Gemfile"

Owner

indirect commented Mar 30, 2010

Thanks for pointing this out. Fixed.

@joevandyk joevandyk pushed a commit to joevandyk/bundler that referenced this issue May 16, 2011

@indirect indirect Resolver conflicts can happen in the Gemfile, so error appropriately
Fixes #227
d025d7e

@joevandyk joevandyk pushed a commit to joevandyk/bundler that referenced this issue May 16, 2011

@indirect indirect Resolver conflicts can happen in the Gemfile, so error appropriately
Fixes #227
c2b0026

This issue was closed.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment