Bundler 1.3.3 and Ruby 1.9.3 undefined method 'dump' for YAML::Module #2393

Closed
grossjo opened this Issue Mar 13, 2013 · 9 comments

Projects

None yet

5 participants

@grossjo
grossjo commented Mar 13, 2013

Trying to run a bundle install that works on bundler 1.3.2 fails on 1.3.3. Error is below

Unfortunately, a fatal error has occurred. Please see the Bundler
troubleshooting documentation at http://bit.ly/bundler-issues. Thanks!
/var/lib/gems/1.9.1/gems/bundler-1.3.3/lib/bundler/settings.rb:129:in block in set_key': undefined methoddump' for YAML:Module (NoMethodError)
from /var/lib/gems/1.9.1/gems/bundler-1.3.3/lib/bundler/settings.rb:129:in open' from /var/lib/gems/1.9.1/gems/bundler-1.3.3/lib/bundler/settings.rb:129:inset_key'
from /var/lib/gems/1.9.1/gems/bundler-1.3.3/lib/bundler/settings.rb:17:in []=' from /var/lib/gems/1.9.1/gems/bundler-1.3.3/lib/bundler/cli.rb:218:ininstall'
from /var/lib/gems/1.9.1/gems/bundler-1.3.3/lib/bundler/vendor/thor/task.rb:27:in run' from /var/lib/gems/1.9.1/gems/bundler-1.3.3/lib/bundler/vendor/thor/invocation.rb:120:ininvoke_task'
from /var/lib/gems/1.9.1/gems/bundler-1.3.3/lib/bundler/vendor/thor.rb:344:in dispatch' from /var/lib/gems/1.9.1/gems/bundler-1.3.3/lib/bundler/vendor/thor/base.rb:434:instart'
from /var/lib/gems/1.9.1/gems/bundler-1.3.3/bin/bundle:20:in block in <top (required)>' from /var/lib/gems/1.9.1/gems/bundler-1.3.3/lib/bundler/friendly_errors.rb:3:inwith_friendly_errors'
from /var/lib/gems/1.9.1/gems/bundler-1.3.3/bin/bundle:20:in <top (required)>' from /usr/local/bin/bundle:19:inload'
from /usr/local/bin/bundle:19:in `

'

mbulat commented Mar 13, 2013

Same here. On ubuntu 12.04 using package ruby1.9.3. Version is ruby 1.9.3p0 (2011-10-30 revision 33570) [x86_64-linux]

Owner

@hone02 :( :( :(

On Mar 13, 2013, at 12:23 PM, Michael Bulat notifications@github.com wrote:

Same here. On ubuntu 12.04 using package ruby1.9.3. Version is ruby 1.9.3p0 (2011-10-30 revision 33570) [x86_64-linux]


Reply to this email directly or view it on GitHub.

grossjo commented Mar 13, 2013

I am also on ubuntu 12.0.4

1st8 commented Mar 14, 2013

+1

pehlert commented Mar 14, 2013

Solution here: #2394 (comment)
I'd recommend using an older version of Bundler for now.

Owner

Here's my speculative patch (also posted on #2394, but I'm going to close that as a dupe of this):

diff --git a/lib/bundler/psyched_yaml.rb b/lib/bundler/psyched_yaml.rb
index 9c878f1..7ce3bb9 100644
--- a/lib/bundler/psyched_yaml.rb
+++ b/lib/bundler/psyched_yaml.rb
@@ -13,7 +13,7 @@ rescue LoadError
 end

 # At least load the YAML stdlib, whatever that may be
-require 'yaml' unless defined?(YAML)
+require 'yaml' unless defined?(YAML.dump)

 module Bundler
   # On encountering invalid YAML,

Can any of you test the patch and see if it fixes the problem?

pehlert commented Mar 14, 2013

@indirect Confirmed, this fixes the issue for me. In lack of better ideas (rubygems version checking would hardly be more reliable), I'd go with this as well.

Many thanks for the quick response!

mbulat commented Mar 14, 2013

@indirect Patch confirmed here as well.

Owner

Great. This will go out in 1.3.4.

@indirect indirect closed this Mar 14, 2013
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment