new rails 4.0.0 Gemfile updated to point to rails 4-0-stable produces dependency errors #2583

Closed
bughit opened this Issue Aug 6, 2013 · 13 comments

8 participants

@bughit
  1. with ruby 2.0.0p247, rubygems 2.0.6, bundler 1.3.5, rails 4.0.0
  2. rails new app
  3. modify Gemfile: gem 'rails', github: 'rails/rails', branch: '4-0-stable'
  4. bundle install
source 'https://rubygems.org'

# Bundle edge Rails instead: gem 'rails', github: 'rails/rails'
# gem 'rails', '4.0.0'
gem 'rails', github: 'rails/rails', branch: '4-0-stable'

# Use sqlite3 as the database for Active Record
gem 'sqlite3'

# Use SCSS for stylesheets
gem 'sass-rails', '~> 4.0.0'

# Use Uglifier as compressor for JavaScript assets
gem 'uglifier', '>= 1.3.0'

# Use CoffeeScript for .js.coffee assets and views
gem 'coffee-rails', '~> 4.0.0'

# See https://github.com/sstephenson/execjs#readme for more supported runtimes
# gem 'therubyracer', platforms: :ruby

# Use jquery as the JavaScript library
gem 'jquery-rails'

# Turbolinks makes following links in your web application faster. Read more: https://github.com/rails/turbolinks
gem 'turbolinks'

# Build JSON APIs with ease. Read more: https://github.com/rails/jbuilder
gem 'jbuilder', '~> 1.2'

group :doc do
  # bundle exec rake doc:rails generates the API under doc/api.
  gem 'sdoc', require: false
end

# Use ActiveModel has_secure_password
# gem 'bcrypt-ruby', '~> 3.0.0'

# Use unicorn as the app server
# gem 'unicorn'

# Use Capistrano for deployment
# gem 'capistrano', group: :development

# Use debugger
# gem 'debugger', group: [:development, :test]
Updating git://github.com/rails/rails.git
Fetching gem metadata from https://rubygems.org/.........
Fetching gem metadata from https://rubygems.org/..
Resolving dependencies...
Bundler could not find compatible versions for gem "railties":
  In Gemfile:
    rails (>= 0) ruby depends on
      railties (= 4.0.0) ruby

    sass-rails (~> 4.0.0) ruby depends on
      railties (4.0.0.rc2)

from: rails/rails#11754
possibly related: plataformatec/simple_form#853

@robin850

I can confirm too with:

  • RubyGems 2.0.6
  • Ruby 2.0.0-p247
  • Bundler 1.3.5
  • On Arch Linux x86-64

I think that this is not related to third-part dependency which would depend on sass-rails 4.0.0.rc2 (at this level Bundler sucks, about a week ago there was a conflict with a version of Mongoid and the pointed gem was carrierwave-mongoid but it was one of its dependencies which was creating a version conflict, but anyway) since I've partially checked and the following Gemfile fails too:

source 'https://rubygems.org'

gem 'rails', github: 'rails/rails', branch: '4-0-stable'

gem 'sass-rails', '~> 4.0.0'

I'm also running Z-Shell with a up-to-date version of Oh-My-Zsh but I don't think that this is related to either Zsh or Oh-My-Zsh ; I've tested this as well on Bash and get the same error. I'm also not using any ruby version manager. Here is the output of bundle env:

Bundler 1.3.5
Ruby 2.0.0 (2013-06-27 patchlevel 247) [x86_64-linux]
Rubygems 2.0.6
GEM_HOME /home/robin/.gem/ruby/2.0.0
GEM_PATH 


Gemfile
source 'https://rubygems.org'

gem 'rails', github: 'rails/rails', branch: '4-0-stable'
gem 'sass-rails', '~> 4.0.0'


Gemfile.lock
<No Gemfile.lock found>
@xaviershay

Pretty sure this is a dup of #2566 please reopen if not (with clarification for my poor brain).

@xaviershay xaviershay closed this Aug 7, 2013
@xaviershay

For the record I could repro the small Gemfile case provided by @robin850

@bughit

with this one, a beta dependency is probably necessary (needs to be confirmed) but not sufficient to manifest, loading rails from git(hub) is required.

@bughit

@indirect, @rafaelfranca is not seeing any rails issues in 4-0-stable, so please reopen this bug, or if you still believe it's rails, identify the specific problematic lines

@bughit

@xaviershay, this bug was closed by you as a dup, but the original has been closed as not reproducible, but this one is, so please reopen

@indirect
Bundler member

Reopening this since it has repro steps for a specific resolver issue, unlike #2566.

@indirect indirect reopened this Sep 11, 2013
@alekseyg

Also having this issue. I don't remember how, but somehow I got around this issue on an older website that I upgraded to Rails 4, and then Rails 4-0-stable because I needed link_to that accepted blocks for that app. On a brand new project, this is happening again.

@robin850 robin850 referenced this issue in rails/activerecord-session_store Oct 21, 2013
Closed

Bundler dependency problem with Rails 4-0-stable #18

@AlexanderPavlenko

This error still does occure in bundle update on 1.4.0.rc.1 while bundle install seems to be working as expected.

@pzgz

This bug is killing me, if there's gem referenced used following gem reference in spec:

gem.add_dependency 'actionpack', '>= 4.0.0.beta'

Then no matter you do bundle install or bundle update, will get following error messages:

Bundler could not find compatible versions for gem "actionpack":
  In Gemfile:
    rails (= 4.0.0) ruby depends on
      actionpack (= 4.0.0) ruby

    actionpack-page_caching (>= 0) ruby depends on
      actionpack (4.0.1.rc3)
@pzgz pzgz referenced this issue in rails/actionpack-page_caching Oct 24, 2013
Merged

Referenced to official rails 4.0 release to avoid the bundler issue #8

@indirect
Bundler member
@johanneswuerbach johanneswuerbach referenced this issue in rails/actionpack-action_caching Oct 31, 2013
Merged

Reference stable rails 4.0 release to avoid bundler issues #8

@rafaelfranca rafaelfranca pushed a commit to rails/protected_attributes that referenced this issue Nov 1, 2013
Rafael Mendonça França Drop support to rc release
This will make possible to install the gem.

Related with bundler/bundler#2583
0619bc8
@bughit

isn't this going to flare up again with rails 4.1?

@Who828
Bundler member

@bughit hey, this is particular bug was caused Bundler's old resolver algorithm.
However, it has been fixed in master as of now.

@indirect indirect closed this Jan 9, 2014
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment