Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

LoadError ... bundler-1.16.1/exe/bundle #6227

Closed
wintersolutions opened this issue Dec 26, 2017 · 12 comments

Comments

@wintersolutions
Copy link

commented Dec 26, 2017

All my gitlab CI builds fail with the new bundler version 1.16.1 with the following error when I use bundle exec:

/usr/local/bundle/bin/bundle:104:in `load': cannot load such file -- /usr/local/lib/ruby/gems/2.4.0/gems/bundler-1.16.1/exe/bundle (LoadError)

	from /usr/local/bundle/bin/bundle:104:in `<main>'

Downgrading to version 1.16.0 is working. Running bundle install beforehand is working. I can't reproduce the error on my local machine with 1.16.1.

The build runs on the ruby:2.4.2 docker image.

@hsbt

This comment has been minimized.

Copy link
Member

commented Dec 26, 2017

What's version of your RubyGems?

It seems RubyGems problem. rubygems/rubygems#2123

@wintersolutions

This comment has been minimized.

Copy link
Author

commented Dec 26, 2017

gem -v
2.7.3

I tried updating to 2.7.4 but the error remains. When I run gem pristine bundler before executing, the error remains.

@wintersolutions

This comment has been minimized.

Copy link
Author

commented Dec 27, 2017

Update: the ruby:2.5.0 docker image has just been released and I can not reproduce the bug with it. Maybe we can close this and chalk it up to the ruby:2.4.2 docker image having issues?

@segiddins

This comment has been minimized.

Copy link
Member

commented Dec 30, 2017

👍 . Let us know if it re-surfaces and we can re-open.

@segiddins segiddins closed this Dec 30, 2017

@jasonkarns

This comment has been minimized.

Copy link
Contributor

commented May 14, 2018

I'm experiencing the same issue on ruby 2.5.1 via homebrew.

$ ruby -v
ruby 2.5.1p57 (2018-03-29 revision 63029) [x86_64-darwin17]
$ gem -v
2.7.6
$ gem update --system
Latest version already installed. Done.
$ gem pristine bundler
Restoring gems to pristine condition...
Skipped bundler-1.16.1, it is a default gem
@jasonkarns

This comment has been minimized.

Copy link
Contributor

commented May 14, 2018

Workaround was to install bundler explicitly instead of using the RG-default version.

@bhagat19

This comment has been minimized.

Copy link

commented May 23, 2018

I had a similar issue with the following configuration

$ ruby -v
ruby 2.5.1p57 (2018-03-29 revision 63029) [x86_64-darwin16]
$ gem -v
2.7.6

However, updating the bundler did help.

gems install bundler

updated the bundler from 1.16.1 to 1.16.2
Seems there is an issue with 1.16.1

@edtamarin

This comment has been minimized.

Copy link

commented Feb 18, 2019

I ma experiencing this issue as well. I am using Redmine, and bundler is needed to install its plugins. My configuration:

$ ruby -v
ruby 2.5.1p57 (2018-03-29 revision 63029) [x86_64-linux-gnu]
$ gem -v
2.7.5

Running a bundler command gives:

$ bundle install --without development test --no-deployment
Traceback (most recent call last):
        1: from /usr/local/bin/bundle:23:in `<main>'
/usr/local/bin/bundle:23:in `load': cannot load such file -- /usr/lib/ruby/gems/2.5.0/gems/bundler-1.16.1/exe/bundle (LoadError)

Running gem install bundler installed the latest version (2.0.1) but somehow it still relies on the old file. Any suggestions?

@mcmichels

This comment has been minimized.

Copy link

commented Feb 18, 2019

Exactly the same error message as @edtamarin
SetUp a compltetlya new parrotOS. Updated all packages. Installed Bundler and ran 'bundler install'

Error:

$bundle install
Traceback (most recent call last):
	1: from /usr/local/bin/bundle:23:in `<main>'
/usr/local/bin/bundle:23:in `load': cannot load such file -- /usr/share/rubygems-integration/all/gems/bundler-1.17.3/exe/bundle (LoadError)

Then i uninstalled bundler and re-installed it. Same error message.

$ruby -v
ruby 2.5.3p105 (2018-10-18 revision 65156) [x86_64-linux-gnu]
$gem -v
2.7.6
@edtamarin

This comment has been minimized.

Copy link

commented Feb 18, 2019

After some digging, I found out that running gem update -- system seemed to do the trick.

@mcmichels

This comment has been minimized.

Copy link

commented Feb 18, 2019

Problem solved myself:
[ ] sudo gem update --system
[ ] sudo gem uninstall bundler
[ ] sudo gem install bundler
[ ] bundle install

Now it seems working

@ice1000

This comment has been minimized.

Copy link

commented Aug 10, 2019

For me, rm Gemfile.lock and rerun bundle install solves the problem

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
8 participants
You can’t perform that action at this time.