v1.2.5

@segiddins segiddins released this Aug 28, 2017 · 6346 commits to master since this release

Bugfixes:

  • install Gemfiles with HTTP sources even without OpenSSL present
  • display CerficateFailureError message in full

1.2.4 (Feb 12, 2013)

Features:

  • warn about Ruby 2.0 and Rubygems 2.0
  • inform users when the resolver starts
  • disable reverse DNS to speed up API requests (@raggi)

Bugfixes:

  • don't send user/pass when redirected to another host (@perplexes)
  • load gemspecs containing unicode (@gaffneyc, #2301)
  • support any ruby version in --standalone
  • resolve some ruby -w warnings (@chastell, #2193)
  • don't scare users with an error message during API fallback

1.2.3 (Nov 29, 2012)

Bugfixes:

  • fix exceptions while loading some gemspecs

1.2.2 (Nov 14, 2012)

Bugfixes:

  • support new Psych::SyntaxError for Ruby 2.0.0 (@tenderlove, @sol)
  • bundle viz works with git gems again (@hirochachacha)
  • recognize more cases when OpenSSL is not present

1.2.1 (Sep 19, 2012)

Bugfixes:

  • bundle clean now works with BUNDLE_WITHOUT groups again
  • have a net/http read timeout around the Gemcutter API Endpoint

1.2.0 (Aug 30, 2012)

Bugfixes:

  • raise original error message from LoadError's

Documentation:

  • platform man pages

1.2.0.rc.2 (Aug 8, 2012)

Bugfixes:

  • clean doesn't remove gems that are included in the lockfile

1.2.0.rc (Jul 17, 2012)

Features:

  • check now has a --dry-run option (@svenfuchs, #1811)
  • loosen ruby directive for engines
  • prune git/path directories inside vendor/cache (@josevalim, #1988)
  • update vendored thor to 0.15.2 (@sferik)
  • add .txt to LICENSE (@postmodern, #2001)
  • add config disable_local_branch_check (@josevalim, #1985)
  • fall back on the full index when experiencing syck errors (#1419)
  • handle syntax errors in Ruby gemspecs (#1974)

Bugfixes:

  • fix pack/cache with --all (@josevalim, #1989)
  • don't display warning message when cache_all is set
  • check for nil PATH (#2006)
  • Always try to keep original GEM_PATH (@drogus, #1920)

1.2.0.pre.1 (May 27, 2012)

Features:

  • Git gems import submodules of submodules recursively (@nwwatson, #1935)

Bugfixes:

  • Exit from check with a non-zero status when frozen with no lock
  • Use latest_release in Capistrano and Vlad integration (#1264)
  • Work around a Ruby 1.9.3p194 bug in Psych when config files are empty

Documentation:

  • Add instructions for local git repos to the config manpage
  • Update the Gemfile manpage to include ruby versions (@stevenh512)
  • When OpenSSL is missing, provide instructions for fixing (#1776 etc.)
  • Unknown exceptions now link to ISSUES for help instead of a new ticket
  • Correct inline help for clean --force (@dougbarth, #1911)

1.2.0.pre (May 4, 2012)

Features:

  • bundle package now accepts --all to package git and path dependencies
  • bundle config now accepts --local, --global and --delete options
  • It is possible to override a git repository via configuration.
    For instance, if you have a git dependency on rack, you can force
    it to use a local repo with bundle config local.rack ~/path/to/rack
  • Cache gemspec loads for performance (@dekellum, #1635)
  • add --full-index flag to bundle update (@Fluxx, #1829)
  • add --quiet flag to bundle update (@nashby, #1654)
  • Add Bundler::GemHelper.gemspec (@knu, #1637)
  • Graceful handling of Gemfile syntax errors (@koraktor, #1661)
  • bundle platform command
  • add ruby to DSL, to specify version of ruby
  • error out if the ruby version doesn't match

Performance:

  • bundle exec shouldn't run Bundler.setup just setting the right rubyopts options is enough (@spastorino, #1598)

Bugfixes:

  • Avoid passing RUBYOPT changes in with_clean_env block (@eric1234, #1604)
  • Use the same ruby to run subprocesses as is running rake (@brixen)

Documentation:

  • Add :github documentation in DSL (@zofrex, #1848, #1851, #1852)
  • Add docs for the --no-cache option (@Fluxx, #1796)
  • Add basic documentation for bin_path and bundle_path (@radar)
  • Add documentation for the run method in Bundler::Installer