New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Incomplete results from taxon search #1

Closed
benj-d opened this Issue Apr 27, 2017 · 3 comments

Comments

Projects
None yet
2 participants
@benj-d

benj-d commented Apr 27, 2017

When using Atlas taxonomy search to find Symphytum the returned taxon tree appears to fall down (no option is returned). If Symphytum officinale is searched for then the species is not returned but the tree returns any sub taxa that contain officinale on the genus search it appears to fail at Magnoliopsida.

genus
officinale

I checked the species names, both genus and bionomial are correct and on the Atlas.

However, if potential relevance, when searching using your taxonomy visualiser the genus entry is returned as Symphytum (indet. Comfrey)
vis

Are the indet. brackets breaking the Gilbert21?

@burkmarr

This comment has been minimized.

Owner

burkmarr commented Apr 27, 2017

It certainly looks that way from your analysis Ben. I will aim look into it further over the week and update you.

@burkmarr burkmarr self-assigned this Apr 27, 2017

@burkmarr burkmarr added the bug label Apr 27, 2017

@burkmarr

This comment has been minimized.

Owner

burkmarr commented May 4, 2017

Hi Ben. I've found the source of the problem with this: the Atlas taxonomy for Symphytum goes straight from class to family and skips order. This caught the G21 code (i.e. me!) by surprise.

I can fix that easily enough, but in the course of investigating it, I've realised that the new taxon tree isn't very helpful for selecting higher level taxa. For example if you do a search on any genus (one that works), the results list the genus and, under it, the species, but you can't click on the genus and get it to fill in the name for you. So I'm going to do a bit more work on this yet before releasing a fix.

burkmarr added a commit that referenced this issue May 29, 2017

@burkmarr

This comment has been minimized.

Owner

burkmarr commented May 29, 2017

This is now fixed in release 3.2.1. Also improved some features of the way that matching results are displayed to users.

@burkmarr burkmarr closed this May 29, 2017

@burkmarr burkmarr changed the title from Symphytum to Incomplete results from taxon search May 29, 2017

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment