Skip to content


Requiring OtherCookbooks #68

vigi009 opened this Issue · 1 comment

2 participants


I am trying to run this cookbook but when i try to upload it says that I require 3 other cookbooks called "build-essential", "7-zip", and "windows". The platform for those are windows, but the virtual machine I am using is running ubuntu, Windows keeps failing when I try to run that. How do I solve this?


If you downloaded the cookbook you can remove the two dependencies from the metadata.rb.

depends 'windows'
depends '7-zip'

I guess I didn't realize that it would be a problem. At least when I run the tests it is not a problem. I'll take a look at that later.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.