Skip to content
This is a mirror of the original repo. Please go there for issues etc.
Dart Ruby Objective-C Java
Branch: master
Clone or download
Fetching latest commit…
Cannot retrieve the latest commit at this time.
Permalink
Type Name Latest commit message Commit time
Failed to load latest commit information.
android Initial commit Apr 3, 2019
assets/fonts Initial commit Apr 3, 2019
images Initial commit Apr 3, 2019
ios
lib Initial commit Apr 3, 2019
.gitignore Initial commit Apr 3, 2019
.metadata Initial commit Apr 3, 2019
LICENSE
README.md Initial commit Apr 3, 2019
pubspec.lock
pubspec.yaml

README.md

yafl

Yet Another Flutter Login starterkit

https://gitlab.com/buzzcat/yafl

This project is a starting point for a Flutter application with working Email/Password, Facebook and Google login (straightforward to add more options such as phone).

There are a few other nice features added and ready such as localization, scoped_model and flushbar error/info messages.

Getting Started

If you do a "Find in Path" in Android Studio on the project and look for "CHANGEME" you will get a list of places that need updating with your own details.

You should read through the following and make sure you fill in the correct details for your own firebase (https://console.firebase.google.com/):

https://pub.dartlang.org/packages/firebase_auth

https://pub.dartlang.org/packages/google_sign_in

https://pub.dartlang.org/packages/flutter_facebook_login (https://developers.facebook.com/apps/)

You can’t perform that action at this time.