Sparse Optimisation Research Code
Clone or download
Brendt Wohlberg
Brendt Wohlberg Fixed bibtex syntax error
Latest commit aa1cde5 Sep 17, 2018

README.rst

SParse Optimization Research COde (SPORCO)

Build Status Code Health Documentation Status Test Coverage PyPi Release Supported Python Versions Package License Binder

SPORCO is a Python package for solving optimisation problems with sparsity-inducing regularisation. These consist primarily of sparse coding and dictionary learning problems, including convolutional sparse coding and dictionary learning, but there is also support for other problems such as Total Variation regularisation and Robust PCA. The optimisation algorithms in the current version are based on the Alternating Direction Method of Multipliers (ADMM) or on the Fast Iterative Shrinkage-Thresholding Algorithm (FISTA).

If you use this software for published work, please cite it.

Documentation

Documentation is available online, or can be built from the root directory of the source distribution by the command

python setup.py build_sphinx

in which case the HTML documentation can be found in the build/sphinx/html directory (the top-level document is index.html). Although the SPORCO package itself is compatible with both Python 2.7 and 3.x, building the documention requires Python 3.3 or later due to the use of Jonga to construct call graph images for the SPORCO optimisation class hierarchies.

An overview of the package design and functionality is also available in

Brendt Wohlberg, SPORCO: A Python package for standard and convolutional sparse representations, in Proceedings of the 15th Python in Science Conference, (Austin, TX, USA), doi:10.25080/shinma-7f4c6e7-001, pp. 1--8, Jul 2017

Usage

Scripts illustrating usage of the package can be found in the examples directory of the source distribution. These examples can be run from the root directory of the package by, for example

python examples/scripts/sc/bpdn.py

To run these scripts prior to installing the package it will be necessary to first set the PYTHONPATH environment variable to include the root directory of the package. For example, in a bash shell

export PYTHONPATH=$PYTHONPATH:`pwd`

from the root directory of the package.

Jupyter Notebook examples are also available. These examples can be viewed online via nbviewer, or run interactively at binder.

Requirements

The primary requirements are Python itself, and modules future, numpy, scipy, pyfftw, and matplotlib. Module numexpr is not required, but some functions will be faster if it is installed. If module mpldatacursor is installed, functions plot.plot, plot.contour, and plot.imview will support the data cursor that it provides.

Instructions for installing these requirements are provided in the Requirements section of the package documentation.

Installation

To install the most recent release of SPORCO from PyPI do

pip install sporco

The development version on GitHub can be installed by doing

pip install git+https://github.com/bwohlberg/sporco

or by doing

git clone https://github.com/bwohlberg/sporco.git

followed by

cd sporco
python setup.py build
python setup.py install

The install commands will usually have to be performed with root privileges.

A summary of the most significant changes between SPORCO releases can be found in the CHANGES.rst file. It is strongly recommended to consult this summary when updating from a previous version.

Extensions

Some additional components of SPORCO are made available as separate extension packages:

  • SPORCO-CUDA: GPU-accelerated versions of selected convolutional sparse coding algorithms
  • SPORCO Notebooks: Jupyter Notebook versions of the example scripts distributed with SPORCO

License

SPORCO is distributed as open-source software under a BSD 3-Clause License (see the LICENSE file for details).