Permalink
Browse files

Configured latest RWT 2.1.0-M2 dependencies. Improved documentation a…

…bout RWT compatibility mode.
  • Loading branch information...
1 parent f3b1c95 commit 075b89543fca483ea58686b0a3e8cb245f379ac0 @bwolff committed Jun 17, 2013
@@ -13,9 +13,9 @@ grails.project.dependency.resolution = {
}
dependencies {
- compile('org.eclipse.rap:org.eclipse.rap.rwt:2.0.0')
- compile('org.eclipse.rap:org.eclipse.rap.jface:2.0.0')
- compile('org.eclipse.rap:org.eclipse.rap.jface.databinding:2.0.0')
+ compile('org.eclipse.rap:org.eclipse.rap.rwt:2.1.0-M2')
+ compile('org.eclipse.rap:org.eclipse.rap.jface:2.1.0-M2')
+ compile('org.eclipse.rap:org.eclipse.rap.jface.databinding:2.1.0-M2')
}
plugins {
@@ -18,7 +18,7 @@ configuration values:
{code}
rwt {
- operationMode = 'SESSION_FAILOVER'
+ operationMode = 'SWT_COMPATIBILITY' // "Required to use blocking SWT/JFace APIs like Display#sleep()"
phaseListeners = [org.example.MyPhaseListener, 'myPhaseListenerBean'] // "Class instances and bean names can be mixed."
themableWidgets = [org.example.MyThemableWidget1, org.exampleMyThemableWidget2]
}

0 comments on commit 075b895

Please sign in to comment.